Dark mode issues with Zotero 6.

The new update is a welcome development. However, I have the following issues with the new update
1. In dark mode (qt) fonts are not visible in the notes section, when not editing, when reading pdfs.
2. The task bar is turned white when a new pdf is opened and this generally distort the dark theme of zotero
3. Hovering over the item panes makes the fonts not visible mostly due to the light blue background and the white colored fonts.

Is there a way to fix all this thank you and keep up the good work
  • Exactly the same issues under GNOME (gtk3).
  • +1 (on arch linux + xfce)
  • edited April 3, 2022
    Same problem here. Any quick fix available?
    In fact, I cannot figure out how to revert to the default dark theme. I cannot find which file contains the information for the dark theme. When looking at dark theme websites, the folders seem different in my user/Zotero folder, and the CSS files are missing. Where is this information stored? This is very disruptive for work as the filenames in the library are completely unreadable after the update.
  • edited April 4, 2022
    Similar problem here, even though I can read entries' and folders' names; also useful that the active tab is in light color with dark text; inactive tabs are with dark text on dark background and this is annoying (although not impossible to cope with)

    Is there a temporary workaround to force light theme and solve the issue ?
    (maybe analogous to that used for dark theme some time ago as listed in: https://forums.zotero.org/discussion/70647/dark-theme-for-main-zotero-window-black-background-white-text)

    I am running Zotero 6.0.4 on Kubuntu 20.04.4 LTS with KDE Plasma Version 5.18.8. Somewhat happy to know that the problem is not depending on my messy config files after upgrade, but nevertheless annoyed by the issue.


    as a workaround I installed the dark theme provided here: https://github.com/Rosmaninho/Zotero-Dark-Theme

    This shall solve the visibility issues, at the price of working with dark theme.

    Starting from the same code it shall not be too hard to create a coherent light theme (just changing the HEX values) to be used to override the default one.

    For the time being I keep using the dark one a I do not have the time of playing with the file; shall I do it before another solution comes out I will keep you informed.

    I hope this helps
  • I also have a similar problem. The new tab in Zotero 6.0.12 shows a black background with black text.
  • I didn't really like the Zotero-Dark-Theme repo but I didn't want to change my whole system to light mode. If you're on gnome I modified the zotero.desktop file in ~/.local/share/applications so that the line:
    Exec=bash -c "$(dirname $(realpath $(echo %k | sed -e 's/^file:\/\///')))/zotero -url %U"
    included an override for the GTK_THEME variable:
    Exec=bash -c "GTK_THEME=Pop $(dirname $(realpath $(echo %k | sed -e 's/^file:\/\///')))/zotero -url %U"

    For me the override was to "Pop" but I think ":light" should work for base gnome.
  • Thanks, @jysdoran!

    In my case, the `zotero.desktop` was located here: `/usr/share/applications/zotero.desktop`

    The desktop entry looked like this:

    [Desktop Entry]
    GenericName=Zotero Standalone. Is a free, easy-to-use tool to help you collect, organize, cite, and share your research sources.
    Exec=env GTK_THEME=Pop /usr/bin/zotero -url %U

    I also had to install the pop theme:
    yay -S pop-gtk-theme

    I'm using Arch Linux.

    It works!
  • Can confirm on Ubuntu 20.04.1

    Had to install pop theme:
    sudo apt install pop-gtk-theme

    zotero.desktop` was located here: `/usr/share/applications/zotero.desktop`

    Final desktop entry

    [Desktop Entry]
    Exec=GTK_THEME=Pop /usr/lib/zotero/zotero --url %u
    Description=Zotero is a free, easy-to-use tool to help you collect, organize, cite, and share research
  • @jysdoran

    In my case (Ubuntu 22), even after changing the zotero.desktop file accordingly, nothing changes.
    I keep having black text on inactive (black) tabs, impossible to read.
    I made sure to have installed the pop-gtk-theme before.

    Any github proposed dark-mode don't apply any change either.
  • Got the same or similar issue with Fedora KDE spin, Zotero as Flatpak. This applies just to Flatpak, but I guess in theory it's similar with other packaging-formats.

    What I did was:

    1. sudo dnf install adwaita-qt5

    # Make a copy of the existing Zotero desktop file if you have not already done so:

    2. cp /var/lib/flatpak/exports/share/applications/org.zotero.Zotero.desktop ~/.local/share/applications/org.zotero.Zotero.desktop

    # Open the copied desktop file with a text editor, for example:

    3. sudo nano ~/.local/share/applications/org.zotero.Zotero.desktop

    # Find the line that starts with Exec= and change it as follows:

    4. Exec=env GTK_THEME=Adwaita GDK_BACKEND=x11 flatpak run --branch=stable --arch=x86_64 --command=zotero --file-forwarding org.zotero.Zotero @@u %U @@

    What we've done:
    Save the file and close the text editor. The original desktop file is located in the /var/lib/flatpak/exports/share/applications/ directory, which is reserved for the flatpak applications and their system-wide settings. Changes to this file could be overwritten when the application is updated or affect other users on the same system. By copying the desktop file to your personal ~/.local/share/applications/ directory, we create a user-specific version of the file that takes precedence over the system-wide version. These changes apply only to your user and are not affected by application updates or changes to system-wide settings.
  • Is there a planned fix in a future update Zotero.
  • For (3) you can add the following to your custom css:

    #zotero-item-pane-content .zotero-clicky:hover {
    background: none !important;
    border-radius: 0pt !important;
    border: 1px solid #b35a57 !important; }

    thanks to: https://github.com/Rosmaninho/Zotero-Dark-Theme/blob/main/userChrome.css for helping me track down the right css selector
  • @jesse.x.knight

    Do I have to copy the whole github code and change that part?

    I only copied what you posted and it didn't work.
Sign In or Register to comment.