Can't copy / paste from PDF in new built-in reader

Apologies if this has already been addressed, but I can't seem to get selected text to copy directly from a PDF in the new built-in reader (which I'm loving, btw). I can select it, right click, and click "copy, but when I go to paste it into Word, it doesn't show up (I get whatever I last copied from a different application). I tried copying from a highlighted annotation, but I can't seem to get that to work unless I first open a note, drag the annotation in, and then copy it, which adds a ton of steps compared to just selecting the text in the PDF and right-clicking. I'm using Zotero 6, Windows desktop app. Thanks!
  • Hey,
    I can on windows 10,
    with both ctrl-v, ctrl-v
    or right-click, ctrl-v.

    Maybe pull some more details on your setup?
  • I'm having the same issue when using the right-click > copy option. Using CTRL+C, however, does work as expected. (Zotero 6.0.2 on Windows)
  • Thank you both for the encouragement to try other routes that my fried brain wasn't thinking of!! Goodness. For the developers, here are my results:

    1) right click, copy in Zotero reader, right click, paste in Word = fail
    2) right click, copy in Zotero reader, ctrl V = fail (most of the time, I think... although I thought that worked once, and it appears to have worked for moore.709)
    3) ctrl C in Zotero reader, right click, paste in Word = success
    4) ctrl C in Zotero reader, ctrl V in Word = success

    I'm using Zotero 6.0.2 in Windows 10.
  • I still can't reproduce this. Can you try with more PDFs or even on a different computer?
  • This is really strange... I just tried it again this morning, same computer, haven't even closed Zotero or Word since yesterday... and now all of the routes are working! Weird, but good. Hopefully it holds, but at least the ctrl+C option was consistently working yesterday once I tried it. Not surprising that there might be some bugs to work out with a new version. Thanks so much everyone!
  • I have been having this problem in Windows 10.

    Trying to copy comments, or sections of text from a pdf viewed in Zotero, did not work. When I went to paste the copied text into Obsidian, there was nothing to paste. This occurred whether I copied using ctrl+c or selected "copy" from the "edit" menu in Zotero.

    After restarting my computer, copying is now working for me again.
  • I had a similar issue, only with newly highlighted sections of text in a PDF. Restarting the Zotero app seemed to fix it.
  • I have the same issue.

    I can't use right click-copy, it doesn't work.

    But I am able to copy with Ctrl + v.

    I am on Windows 11 Pro 22H2
  • Same issue here on Windows 10 Pro - only after Hibernation.
    I have Zotero set as a startup program in Windows and it performs flawlessly on initial startup. Cut and Paste into Word/Chrome etc etc.
    If the machine is Hibernated then, upon resuming, cut and paste from the built in pdf reader is sometimes patchy or fails to work at all using any of the above described methods.
    Close and reopen Zotero - it all works fine.
  • I am facing this issue in Zotero 6.0.23 on Windows 10.
  • @vjydubey: You have to say exactly what you're doing and what's happening.
  • @dstillman in the zotero PDF viewer when after I select some text and do copy (either with 'Ctrl+C' or with right click→copy) the text isn't copied to the clipboard. When I paste it somewhere else (to say google about the text) it won't show up.

    At the moment this behavior appears random: (a) sometimes isolated to one among many open files and other times it effects all the open files. (b) restarting zotero can remedy it for the same files. If I notice any pattern in the behaviour I'll report it back here.
  • @vjydubey: If you have any third-party plugins installed, confirm that this happens with those disabled. If you can reproduce this with all plugins disabled, we'd want to see a Debug ID for it happening.
Sign In or Register to comment.