Scite plugin not working (Zotero 6.0.1)

edited March 22, 2022
I recently installed the scite Plugin in Zotero and was running fine. But when I tried to update the date of a paper that the metadata wasn't extracted, it didn't let me do it, so I restarted the program. After that, Zotero won't let me in because of a crash and close after that.

I already was able to open Zotero with the information from this forum:

But after opening Zotero again, the scite add-on wasn't working. Is there anything I could do about it? Because before the crash everything was alright. The report ID of the problem was: 1242971040.

  • edited March 22, 2022
    Disable the plugin immediately.

    The plugin seems to be doing something that's causing invalid values to be saved to the database, which is going to cause widespread breakage.

    They're investigating, but for now it's not safe to have enabled.
  • I removed the addon, but wasn't able to sync my library after that. I keep getting a crash when I try:

    'accessDate' must be in ISO 8601 or UTC 'YYYY-MM-DD[ hh:mm:ss]' format or 'CURRENT_TIMESTAMP' ()

    I uninstalled multiple times to see if it works, but nothing.

    Thanks for the patience.
  • edited March 22, 2022
    Update: See below.

    OK, the Scite developers have pushed a new version that disables all functionality while they debug this.

    Once you've installed plugin version 1.11.4 (and only once you've done that), go to Tools → Developer → Run JavaScript and run this:

    await Zotero.DB.queryAsync("UPDATE itemDataValues SET value='INVALID_SCITE_VALUE' WHERE value=0"); return await Zotero.DB.queryAsync("DELETE FROM itemData WHERE fieldID=(SELECT fieldID FROM fields WHERE fieldName='accessDate') AND valueID=(SELECT valueID FROM itemDataValues WHERE value='INVALID_SCITE_VALUE')") || 'done'

    Then restart Zotero.

    This will replace all invalid values with the string 'INVALID_SCITE_VALUE', which should prevent further errors and allow you to find and correct them.

    If you find after this that many fields were mangled, you can try reverting to one of your automatic backups.

    The Scite columns will remain disabled until they fix the underlying problem and push a new version.
  • Hey everyone,

    It should go without saying but very sorry for the inconvenience this has caused, I hope that by disabling and the workaround Dan provided it mitigates how severe the issue is.

    I'm working on a fix to get it working now that I can reproduce it reliably now; until then it'll be disabled as Dan says.

    I have a working fix locally so hopefully it doesn't go out of commission for too long.

    Thanks to everyone who helped triage this, and my bad again for letting this one slip through.

  • edited March 22, 2022
    @dstillman , for someone who has the scite plugin installed, but has not noticed any issues in brief Zotero 6 runs, and does NOT currently have Zotero running, what is the best strategy ? The above fixes seem to be for people who have already encountered the problem and/or have Zotero currently running, correct ?

    Should I disable?/remove?/update? the scite plugin manually before starting Zotero ? If so, how ?

    Or is it safe to start Zotero and then disable the plugin (before performing any other operation) ? Disable auto sync ? (is it possible/necessary to do this before starting Zotero ?).

    Or should I wait for the next Zotero release before starting Zotero ?

    I have just made another backup of my Zotero sqlite files as they stand now, just in case.
  • edited March 22, 2022
    @timwr820: Good question. Safest is to go into your Zotero profile directory, open the 'extensions' folder, and delete You can then start Zotero and reinstall version 1.11.4 of the plugin, which has all functionality disabled. When the next plugin update comes through tomorrow, the functionality will be restored.

    Still a good idea to run the above command to clean any rows that were corrupted. We're looking into what we can do to clean those automatically in a Zotero update.
  • edited March 22, 2022
    I've updated the above command with some additional code to remove access dates broken by the plugin, which would cause sync errors.
  • edited March 22, 2022
    I deleted the scite plugin in my profile folder as instructed. From the file dates in the XPI/ZIP, the scite code was a month old so I am assuming I had v1.11.2 of the plugin (I don't know how to find the actual version number in an XPI file). I had not fired up Zotero since yesterday, so I assume that's why I didn't have the scite v1.11.3 update ... which is the culprit I think ?

    I then fired up Zotero. But selecting Tools / Add-ons did not bring up that dialog. No sign of scite column names under right click but the scite tab in the right window was still there. Zotfile preferences option is present in Tools menu but it does not bring up the dialog. All recently added references are intact.

    Is this expected ? Does Zotero still think the Scite plugin should be available and gets confused when the XPI isn't there to be loaded ? I was loath to install Scite v1.11.4 until the dust settles. But will the rest of the Add-ons functionality not work until I do ?
  • @timwr820: Try deleting extensions.json in your profile folder.
  • @dstillman : OK I deleted extensions.json from my profile folder.

    But on Zotero restart, Tools\Add-Ons still brings up nothing. Extensions folder contains XPIs for zotfile, zutilo, scihub, navigate. Scite tab in right window is still there, right click scite column names still gone. Zotfile prefs still under Tools but still does not bring up window. Tools\Zutilo prefs is there and does open its window. Scihub tab under Edit\Preferences is there.

  • same here as timwr820:
    - tools/add-ons does not respond -> but fixed in update Zotero just yet (bravo!)
    - plus: Word claims that Zotero-plugin is outdated. After reinstall Zotero-plugin: cannot opden document template Zotero.dotm. So Word integration is out of order as well.

    I do not see any mayhem in my database, but is 10000 entries. So I should try the option below?
    "This will replace all invalid values with the string 'INVALID_SCITE_VALUE', which should prevent further errors and allow you to find and correct them."

    then search on 'INVALID_SCITE_VALUE' in 'Everything'?
  • I tried dstillman's option: "This will replace all invalid values with the string 'INVALID_SCITE_VALUE', which should prevent further errors and allow you to find and correct them."

    then searched on INVALID_SCITE_VALUE. In 'Everything' I get an enormous amount of hits, seems to be all entries with attachments.
    But: all entries are greyed, all attachments are black, suggesting that the string INVALID_SCITE_VALUE is in the (mainly) pdf's.
    Searching INVALID_SCITE_VALUE in the attachments/pdf's yields nothing.

    Searching INVALID_SCITE_VALUE in All fields & Tags gives zero hits.

    Is this repairable? Or repairable in future?

    It does not seem to hurt the database that much since all fields seem to be fine. Should I restore zotero.sqlite.111.bak 17-03-2022 23:54 -a--

    That would give me some orphaned attachments and undo's of recent changes in the database I guess
  • 'No scite tallies' under the scite tab.
  • @dstillman : Following on from deleting the scite XPI and extensions.json, which led to Tools\Add-Ons not working, I have now done a Check for Updates (I am on 6.0). That brings up the Software Update window that shows Downloading Zotero ... Applying Update. But it never completes - first time I left it for over an hour. I can close that window (with top right X), but About Zotero still shows version 6.0. And Tools/Add-Ons still doesn't open its window. Same after restart.
  • Hi again --

    On v1.11.4 of the scite plugin, all scite plugin behavior is disabled (to give Dan & team a reprieve in order to minimize any damage from the bug).

    I released 1.11.5 (link below) which re-enables the plugin and fixes the bug, verified on both zotero 5 and 6 on three different user's libraries.


    (Or, if you already have 1.11.4, you can upgrade it from Zotero itself).

  • My Zotero is completely updated. I have removed sclite altogether and on restarting again, Zotero has returned to normal, except that four other add-ons are declared to be incompatible with Zotero 6.0.1.
  • edited March 22, 2022
    @stroom: That's just an artifact of the Everything search — that's just matching anything with "value" in it. The All Fields & Tags search is all that matters.
  • edited March 22, 2022
    OK, Zotero 6.0.2, out now via Help → Check for Updates or the download page, will automatically convert any field values corrupted by the Scite plugin to "INVALID_SCITE_VALUE".

    After upgrading, you can search for "INVALID_SCITE_VALUE" in All Fields & Tags mode in the root of each library to see any affected items and correct the values yourself.

    Again, if you find after this that many fields were mangled, you can try reverting to one of your automatic backups.

    With Zotero 6.0.2 and Scite plugin version 1.11.5, you should be all set.
  • edited March 23, 2022
    Further to my earlier report that Zotero 6.0 would not complete the update, it eventually did. Not sure how long it took because it was going overnight. So that took it to 6.0.1, where the Tools\Add-ons window then opened again as it should. And then doing Check Update again took it quickly to 6.0.2.

    No INVALID_SCITE_VALUEs were found, probably because I had not run Zotero yet on the day that scite 1.11.3 released, so I only had 1.11.2 when I removed its XPI from the extensions folder.

    So all is apparently back to normal. The only apparent remnant of scite is the scite tab in the right window (which seemingly does nothing). I will probably update to 1.11.5 at some point.
  • edited March 23, 2022
    @timwr820: Updates only take a few seconds. If they ever take longer, it's just stuck and you should restart. If it's still not working, reinstall from the download page.
  • edited March 23, 2022
    Correction to my last report: Just looked in my extensions folder, and it now has scite v1.14.1 ! (version confirmed under Tools\Add-ons). So it updated itself somehow even though I had removed its XPI (v1.12.1) earlier, and (later) deleted the extensions.json that still referred to it. I had run Zotero several times since removing the scite v1.12.1 XPI and I checked that the scite XPI had not returned to the extensions folder. So something subsequently triggered it to download 1.14.1 (maybe the two Zotero updates ?).

    I then ran check for updates under Add-ons, and it updated Scite to 1.15.1 (and Zotfile to 5.1.1). Scite right click columns are now back.
  • Hey guys,

    Is scite or bbt's custom columns working for you guys? I couldn't get it working on my end. Win 10, Zotero V6.0.4

  • @whalp Did you right-click on top of the columns, and choose the relevant columns to be added to the view?
  • Thanks. I did it before but didn't notice that the columns were there.
    I assumed that when I installed scite, that the columns would be there like before lol.

Sign In or Register to comment.