Unable to add citations in footnotes

I use Zotero on a daily basis. My preferred citation style is Chicago with footnotes. Often, I will want to add further information to a footnote that already includes Zotero citations. For example the footnote might be "Alice, 2022." But I then want to add information (including citations) that can't be in that single footnote. E.g., "Note that Bob 2022 doesn't replicate her study." Unfortunately, when I try to do that in certain footnotes in the document I'm currently working in, I receive error messages.

I followed the troubleshooting suggestions here (https://www.zotero.org/support/kb/debugging_broken_documents). But two things make it difficult:

(1) The footnotes that do and don't work seem arbitrary
(2) Even if I identify one citation that fixes the problem for one part of the document, I still encounter the same error in other parts of the document.

Can anyone help me out here? Thanks!

Report ID: 1560851246
OS: MacOS Montery 12.2.1
Word version: 16.58
  • edited March 19, 2022
    [JavaScript Error: "complete() method already called on document" {file: "file:///Applications/Zotero.app/Contents/Resources/extensions/zoteroMacWordIntegration@zotero.org/components/zoteroMacWordIntegration.js" line: 426}]
    [JavaScript Error: "The operation couldn't be completed. (OSStatus error -1728.) @[checkFieldIntegrity:field.m:156]" {file: "file:///Applications/Zotero.app/Contents/Resources/extensions/zoteroMacWordIntegration@zotero.org/components/zoteroMacWordIntegration.js" line: 264}]
    Have you tried restarting Zotero and Word?
  • Yes. I also uninstalled and reinstalled Zotero
  • Try with Zotero 6.0.1, just out; that fixes at least some footnote-related issues
  • Thanks! I think that fixes the issue!
Sign In or Register to comment.