Font rendering

Firstly, thanks for the new version! I'm looking forward to using the new features.

But I have a problem with font rendering. It appears that the line height is off, but not in the item pane. The result is that descenders are cut off.

I tried fiddling with the View->Font Size menu to no avail. I tried fiddling with and The first was set to 9 and the second was set to 89. Changing them both to 13 and restarting didn't make a difference. Resetting them to their defaults (12) didn't help either.

Finally, this is my laptop on which I am having this problem. My desktop is fine. Both are running Arch Linux (laptop 5.16.15-arch1-1, desktop 5.15.29-1-lts).

Any ideas?

  • Can you take a screenshot, upload it somewhere (e.g., Dropbox or Google Drive), and provide a link here?
  • Have you changed your OS font size/scaling settings from the defaults?

    We're looking into this and similar reports, but I suspect this only happens when the OS font settings have been changed.
  • I am using XFCE4 (v4.14 or v4.15) on both my laptop and my desktop. I've used the Appearance widget to change my default font to Fira Sans Condensed Regular 15 and my default monospaced font to Fira Code Regular 13. I used the Window Manager widget to change the title font to Fira Code Sans Compressed SemiBold Italic 13 on my laptop, and a custom DPI setting on my laptop (115 dpi). I use the default theme. Fonts are rendered with anti-aliasing and full hinting. The sub-pixel ordering is RGB.

    I forgot to mention that I had no issues with 5.0, and I've been using Zotero for about 3 years.
  • FYI: My scaling is set to 1.0 (the default).
  • I'm also having this issue. (Ubuntu Wayland, using the Flatpak version of Zotero).

    My font scaling is set to 1.25, and in Gnome Tweaks my interface font is set to 14.

    If I reduce the interface font to 12, the clipping goes away - but the text is too small to read.

    I've had a fiddle in the advanced config editor, but I can't find anything that works.

    I love the rest of Z6 - but this is a little bit frustrating.
  • @TerenceEden: What happens if you set the font scaling to 1.0 and restart Zotero?
  • If I turn Font Scaling to 1.0 - the text doesn't get cut off.

    But it is now too small to read.

    If I increase the font size from 14 to 18, with font scaling 1.0 - it gets cut off at the bottom again.
  • Adding this to the userChrome.css

    .row{ height: 1.5em !important;}

    Improves the spacing when an item is highlighted. But I need to find a way to stop the rows from overlapping.
  • Just to let you know we're looking for a way to fix this, but it's not an easy issue to address so won't happen immediately.
  • I have exactly the same issue. My system is also Linux.

    Making default GTK font size small and scaling Zotero font size can mitigate the problem, but that would change all gtk applications, including Zotero's toolbar. Is there a way to change the font size of the item list?
  • We'll have a fix out soon. Sorry for the trouble.
  • This should be fixed in the latest Zotero beta. If you try that, let us know if it fixes the problem for you.
  • My issue with leading has been fixed!!! May the gods be praised! (Thank you.)
Sign In or Register to comment.