Bug with hiding and showing annonation citations and custom template

edited April 19, 2022

1. Go to Advanced pane of the Zotero preferences, open the Config Editor, and search for "annotations.noteTemplates"
2. Edit "extensions.zotero.annotations.noteTemplates.highlight" and change it to <blockquote>{{highlight}}<br><br>{{citation}}</blockquote><p>{{comment}}</p>
3. Open a document and make some annotations.
4. Press "Add item notes from annotations" in "Item Notes" (panel on the right)
5. Click on that new note. Notice the empty space between highlighted quote and citations.
6. Click on triple-dot selector (top-right corner) and press "Hide annotation citations".
7. Go to the same place and enable it now.
8. Bug: highlight and citation are displayed on the same line.
  • edited April 19, 2022
    A new one with duplicating citations:
  • Any response? Should I just create an issue on GitHub then, since this is a clear bug?
  • We'll investigate.

    (To include code here, wrap it in <code></code> tags. I've fixed your posts.)
  • edited May 31, 2022
    I just stumbled accross this as well.

    To put it another way, when using blockquotes, the citation appears below the annotation not behind it like I think it should. And instead of the option to hide annotation citations, there is an option to show them. When this is clicked, another citation appears behind each annotation, so each citation then appears twice.

    I'd like to copy these annotations to a markdown editor, so having to manually remove each duplicated citation is quite inconvenient.
Sign In or Register to comment.