Cannot leave citation field in LibreOffice Writer

Hi everyone,

I use the Zotero connector with LibreOffice Writer. After inserting a citation, I often cannot type after or before the inserted special field because Writer assumes I am still inside the special field. I do NOT want to edit the citation, I just want to continue writing but I can’t. It sounds stupid but I can’t find a way to add text after / before the field. Sometimes it works bust most of the time it does not. How do I leave the field?

LibreOffice version is Zotero version is Operating System is Manjaro Linux with the Gnome Desktop.
  • This is a known issue. You can try posting one the document foundation bug report that you are affected, which might draw somebody's attention who could fix it, but it didn't help in the past.
  • @Konzertheld Please do post to the link above. This is a LibreOffice bug that has long been ignored or, perhaps, ranked as minimally important. It can only help if new comments are posted about this frustrating issue.
  • I see. Thanks for your answers. With over 6000 bugs for Writer alone, it's probably faster to spin up MS Office on a virtual machine.
  • edited March 11, 2022
    Update: The currenty advised workaround is to use bookmarks instead of reference marks. Indeed, I cannot reproduce the probems with bookmark-style citations. Are there any drawbacks other than not being able to use them as footnotes?

    (Source: )
  • edited March 11, 2022
    I think that you will be exchanging one problem for another. Even with this reference-field-extension problem, I still use ReferenceMarks with LO documents.


    "Bookmarks can cause errors if accidentally modified, so they should only be used if compatibility between Word and LibreOffice is necessary"

    edit: Rereading the Ask LO link ... this is a recommendation by one LO user in 2019 and is not endorsed by anyone since.
  • edited March 11, 2022
    I confess that when I must edit my LO document near a live ReferenceMark, I find it easier and quicker to delete the Zotero Mark and a few words before and after it. It only takes a few seconds to retype the text and reinsert the Zotero field. I've learned to accept my annoyance with the Document Foundation bug gatekeepers who degrade the importance of this LO bug. That doesn't mean that my recommendation for LO users to report the bug isn't important. It might help if all LO users here report the bug to the link given by @adomasven above.

    Until the bug gatekeepers understand that writers of technical documents want to use LO and that this bug affects a wider population than Zotero users; this will remain a low priority.
  • Is it possible we still have this bug?

    it's very frustrating :(

    currently I type enter to go to a new line (this seems to break the "we are still inside the citation thing), type a space, type left arrow, and then type backspace to go back to the previous line
  • This is _not_ a Zotero bug. Please re-read my comment immediately above. Please contact the Document Foundation and report this bug in LO Writer.
  • I understood that!

    Is there no workaround that Zotero can put in place?
  • I have also had a similar behaviour in MSword before. So, for both LO and MSword I usually turn off the track change mode (does seem to help occasionally) and preempt the problem by double spacing and going back one with the left arrow key before inserting the reference.
  • Quoting Commit Notification, I've """committed a patch related to this issue.
    It has been pushed to "master":

    tdf#81720 Don't expand Reference Marks

    It will be available in 7.6.0.

    The patch should be included in the daily builds available at in the next 24-48 hours. More
    information about daily builds can be found at:

    Affected users are encouraged to test the fix and report feedback."""

    It should fix the issue, please do give it a try!
  • I can confirm the linked fix in master fixed the problem for me. (I used the build of libreoffice-dev-bin from the Arch User Repository.)
  • Thank you very much!

    I'll test it when 7.6.0 will be released in mid-August.
Sign In or Register to comment.