Zotero connector not passing through complete bibliographical information

The zotero connector button in chrome has stopped passing through much of the data for my library catalog (University of Chicago). Specifically, I no longer get the call number, and it adds a forward slash after the title. I have compared behavior to another library catalog (Stanford) which does pass through all of the expected data, so this seems to be unrelated to my specific installation/devices (and I did check in other browser/computer installations just to make sure).

It stopped giving me library catalog call number data around November as far as I can tell -- any tips on whether this can be fixed somehow? Thanks.
  • Can you provide an example URL?
  • yes


    yields slash after title, no library catalog location, no place of publication. Only data is type, title, author, publisher, date, isbn.
  • Hi - bumping this with some further info.

    URL of page I tried: https://catalog.lib.uchicago.edu/vufind/Record/624835
    Debug ID: D881171844
    When I try to save: does saving to my library but does not pass through info
    Name of translator: CoiNS

    From what I understand the problem here is that it's using the generic translator for the University of Chicago library catalog. I am able to use other library catalogs with no issue. Thanks for any info you might be able to offer.
  • Nothing has changed on Zotero's end -- there never was a dedicated translator for the UofC discovery layer (VuFind).
    If this worked previously, I'm wondering if they removed some embedded information -- the catalog may have exposed additional metadata in the past.

    Generally it wouldn't be hard to support the catalog, it's just a question of doing so in a way that's sufficiently broad (i.e. includes other vufind installations).
  • Yeah, it has worked for years and just stopped working around October/November judging from my zotero library. I will try following up with someone at the library.
  • Could you check what it says in the "Library Catalog" field for the items that imported successfully?
  • it says catalog.lib.uchicago.edu
  • edited February 27, 2022
    OK, I just found an announcement on the library webpage that they changed the library management system in January to something called FOLIO. They have a recent update on the migration that mentions this outstanding issue" "Some record information is not displaying correctly on Full Record pages. While major fields such as Title and Author are consistently displaying, records are sometimes missing fields such as Notes and Other Authors / Contributors." Presumably that's the explanation.
  • Still worth reporting the Zotero import regression. That's a different issue from the missing fields.
  • Thanks, yeah, I sent them a note.
  • @AbeJellinek added a couple of vuFind based translators last summer, he'd be in the best position to see if we can add an improved translator here, independent if UofC fixes
  • Hi, this is the product owner for VuFind at UChicago. Our team is currently working on restoring Zotero support for the catalog here. We're leaning towards deploying a translator, since VuFind already generates valid MODS RDF for each record. We'd just need to point Zotero to it. However, I'm not having much luck finding the previous VuFind translators you mention. Do you recall what any of them were named? Thanks!
  • Awesome, thanks @dbietila
    That'd be Pika and Finna
    No idea how heavily those are modified

    The alternative would be to implement unAPI and point that at the MODS (https://web.archive.org/web/20141218062835/http://unapi.info/ -- yes I know, the main site is down, but it's still a nice protocol)
Sign In or Register to comment.