ipad/ios app: Some files take eternity to download

I have been waiting for over 10 minutes for file of a few MBs to download and open up. And it is still not open. I have restarted the app multiple times.


Please add an option to keep the whole library or a collection downloaded. I makes it really unreliable when files don’t open as and when needed

PS. I am using webDAV and doesnt seem to be a problem with the cloud as other files are being downloaded…with hit and miss.
  • edited January 29, 2022
    (+0042599): HTTP GET https://ewebdav.pcloud.com/zotero/5KVEES2S.zip failed with 200
    [ERROR] Zotero(+0000000): Download failed
    You're using pCloud, which is extremely unreliable and the source of countless posts here over the last few months. Switch to another provider or use Zotero Storage.

    There will be an option to download all files once Zotero is out of beta, but the problem here is your WebDAV provider, not Zotero.
  • Oh. Okay.
    Will switch to something else in that case.
  • I have the same problem when switching from Papership to Zotero iOS app this morning. I'm using Koofr as a WebDav provider and it is still working fine with Zotero Desktop and Papership on my Ipad. However, it doesn't work with Zotero iOS. The download process takes like an eternity without any progress. Thanks.
  • edited March 24, 2022
    I found that sometimes it lost the lastsync.txt file causing that problem. Solved.
  • @doviettung96: We'd need to see a Debug ID for a download that's slow to say more.
  • @dstillman don't worry. The problem belongs to the cloud provider itself. I have fixed it by adding a dummy text file called lastsync.txt.
  • @doviettung96: No, that's incorrect. That was a file that was required by old versions of Zotero and by the third-party Papership app on iOS. It's definitely not required for the new iOS app and had nothing to do with fixing this for you.
  • @dstillman hmm.. quite strange. I can immediately download the items after I add that file.
  • It was a coincidence. There's literally no code in the entire iOS app related to that file.
Sign In or Register to comment.