Report: Google Docs Integration not letting me sign in

Report ID: D810360041
Firefox version: 96.0.2
Zotero Version:

Today, I was re-opening a Google Doc I was working on that already contains zotero citations inside. For some reason when I clicked on the refresh / document preferences from the drop-down menu I see the loading bar appear and the sign-in window pop-up but I can't see the window unless I completely close all Firefox tabs and re-open them. However even when I click on my account to sign-in via the new window, the document doesn't let me add any citations or edit any Zotero-related settings within the document. Rather, nothing happens if I try to click on anything, it's as if the Zotero integration wasn't there.

I tried disabling my other Firefox add-ons, restarting Firefox, restarting my computer with the same results. When I went to check the version of the Zotero connector, oddly it doesn't display the version, but instead this message: "Zotero is currently available." However the connector seems to connect to the my local zotero fine since it prompts me to open the software if it's closed.

I tried testing it with a blank Google Doc file, as well as a blank MS Word file. The google doc behaved the same way as described above. The word file doesn't load anything up.

Any help would be appreciated.

  • Solution: From the local Zotero software, go to Edit > Preferences > Cite tab > Word Processors > Reinstall Microsoft Word Add-in. Close both local Zotero and Firefox browser and re-open them to test on MS Word and Google-Docs.

    This fixed the problem both in Google Docs and in MS Word. Not sure how this happened, so it may be a new update that changed the settings or I accidentally changed something in the settings.

    Sorry for the miss-fire!
  • edited January 26, 2022
    The Google Docs authentication window opens as a separate browser window, so if you accidentally switch away from it, you need to look for it in the open window list. Closing all Firefox tabs eventually focused the other Firefox window that was open for google docs authentication.

    As a separate note, if you close the Google Docs window mid-Zotero action, like when Zotero waits for Google Docs authentication, you will get Zotero integration "stuck" and it won't work again unless you restart Zotero. Unfortunately we don't have a better way for Zotero to get unstuck - it simply does not know whether Firefox will ever respond to its document integration request.

    So if you ever run into a situation where document integration actions don't do anything, restart Zotero, first check if you don't already have a Zotero citation window open (in the window list), then restart Zotero. Similarly, if you accidentally lose the Google Docs authentication window, just look through open Firefox windows.
  • Thanks adomasven, I'll keep that in mind.
Sign In or Register to comment.