Zotero crashing when I try to insert a citation into Word

When trying to insert a citation using the Zotero menu in Word, it won't let me navigate and select an item from the library. The cursor goes to a doughnut shape when leaving Word after selecting Add / Edit citations from the Zotoro menu/bar in Word. This happens every time so turned off my security software to see if that was causing the conflict, but it still happens. I'm using Word (office 365), Chrome, and the latest Zotoro version, so nothing special about my configuration.
Any ideas how to fix this so I can cite?
  • edited January 20, 2022
    it won't let me navigate and select an item from the library
    What do you mean by this? Navigate what? Are you referring to the classic citation dialog? You don't "navigate" anywhere in the default citation dialog, and you don't switch back to Zotero proper to select items.

    Does this happen in a new document as well, or only an existing document?

    Have you tried restarting your computer?
  • I'm a new user and originally thought that after selecting Add/Edit citation from the Zotero menu in word, that you had to navigate over to the Zotero library to select an item.
    Now that I read the user docs, the real problem is after selecting Add/Edit Citation, the pop-up dialog does not get populated with any text I type, such as the first few letters of a library entry or author name. That is the real problem! Checked today and it still happens. Zotero locks up and I have to x out of Zotero to continue using my PC.
    I checked Add / Edit Bibliography, and get the same behavior.
    I can, however, drag and drop an item from the Zotero library to an open Word document successfully.
    So the problem is with the Zotero search dialog - it doesn't allow me to search!
  • Restart Zotero and try again. Make sure there's not another citation dialog — e.g., the Document Preferences window — popping up behind your other Zotero windows.

    If you're still having trouble, we'd want to see a Debug ID from Zotero for an attempt that doesn't work.
  • I just verified the problem - It always happens, its not sporadic - good from a troubleshooting perspective!
    I turned on debug and replicated it, the problem is that there is no way to turn debus off because Zotero is locked up when I toggle back to it. Then when I close Zotero (x out of it then select Close the Program) followed by starting Zotero again, the debug info is lost. (I can turn debugging on again but it starts from scratch.
    For next attempt, I did attempt the "Start debug log upon restart" option, and when I started Zotero again, there was some data in the debug log, which I submitted, but this submission did not come after the problem was reproduced, so doubt it will help.

    Another idea... I could take screenshots of the problem, or better yet, could start a Zoom session and reproduce it on-line while sharing my screen. Would that help? i can send you a Zoom link.
  • Yes, can you make the View Output window as big as possible, trigger the problem, take a screenshot of it, upload it somewhere (e.g., Dropbox or Google Drive), and provide a link here? (If there's anything private you can also email to support@zotero.org with a link to this thread, but we'll respond here.)
  • See the screenshot of the debug log - hope you can read it.

    Also sent to support@zotero.org
  • No — you'll need to either make that publicly visible and provide the share link or send it via email.
  • Will attach to an email to support@zotero.org
  • I'm afraid the screenshot and debug log you sent us doesn't give us much more insight into what's causing it. It might help to temporarily create a new windows user account and see whether it works there, which would indicate some configuration option to be the cause. Otherwise security software could still be the suspect. What security software are you running? Sometimes they can cause issues even when temporarily disabled.
  • I run Mcafee.
    I also run Zoomtext Screen Magnifier / Reader.
    Afraid I can't do without that one though!
  • If you'd like to troubleshoot this, you'll need to temporarily disable them to see if that makes a difference.
Sign In or Register to comment.