zotero:// link not working in debian distro

Hello, I am not able to open a zotero link in obsidian in my linux computer, but in my macOS computer I can. I don't know how to solve this issue. I have seen threads in this forum where this very same issue is discussed, but no proper solution is ever presented.

I am using zotero in both linux (debian 11) and macOS monterey, and zotero is configured exactly the same in both machines.

In linux I installed the debian package you recommend in your download page and everything installed correctly with no issues (I also tested with the tarball). Zotero works fine in every other respect. I don't know if this is relevant but the desktop icon was also correctly created during the installation.

There really aren't many steps to reproduce this issue. I am using mdnotes to export my zotero annotations to markdown format and then I just copy paste the markdown text alongside the zotero links into obsidian. When I click these links in macOS they work and open Preview in the correct page, but when I try the same in linux I get a window with a warning saying there are no applications installed that can deal with this zotero://... link.

Does the zotero installation in linux require further configuration beyond what is required in macOS?

Any help is appreciated.
  • I have found a solution inspired by https://askubuntu.com/a/1098851 that worked for me.

    1. Open ~/.config/mimeapps.list
    2. Append x-scheme-handler/zotero=zotero.desktop; to the end of the [Added Associations] list
    3. Append x-scheme-handler/zotero=zotero.desktop to the end of the [Default Applications] list
    4. Save and close mimeapps.list
    5. Click the zotero:// link in obsidian and it now opens the linked pdf on the correct page

    I am not sure if this was just an issue particular to my machine or if it is more widespread, but perhaps this should be checked regarding the debian package provided in the download page.

    This post can be closed as solved.
  • This worked in Ubuntu 20.04! Thanks hugely
Sign In or Register to comment.