ZotFile doesn't create linked files after carefully following instructions

Hello, I'm trying to use Zotero with a third party cloud service provider. I have tried using ZotFile without much luck.

I have followed the instructions on ZotFile's website, and also many tutorials in the form of videos and documentation in several universities' websites, but still it just doesn't seem to want to work.

Here's what I did:

1. Download and install Zotero 5.0.96.3 (Tried on both Arch Linux and macOS Monterey)
2. Download Zotero Connector for Firefox
3. Open Zotero
4. In Zotero: Go to Edit>Preferences>Advanced>Base directory>MyFolder>Change Base Directory Setting
5. Download ZotFile from zotfile.com and install according to instructions
6. In Zotero: Tools>ZotFile Preferences>General Settings>Source Folder for Attaching New Files>MyFolder
7. In Zotero: Tools>ZotFile Preferences>General Settings>Location of Files>Custom Location>MyFolder
8. Grab some article such as: https://arxiv.org/pdf/2201.04596.pdf
9. Download PDF by clicking on the Zotero Connector icon, which shows a PDF icon
10. Go to Zotero and left click on the new item that appears
11. Right click PDF under item
12. Left click Show File
13. Depressingly realize PDF file is inside Zotero's storage folder instead of MyFolder

Sorry for being so verbose but I am at a complete loss as to why this isn't working and I want to make sure I am doing everything correctly.

To clarify, MyFolder is some folder in my filesystem, which I have tried setting inside OneDrive, Mega, and simply in my Hard Drive outside any syncing service's directory.

I get no errors throughout this process.

Please help...

Best regards
  • ZotFile doesn't work automatically when directly downloading a PDF. You can either
    - Import from the abstract page: https://arxiv.org/abs/2201.04596, which will automatically attach the PDF which ZotFile then *will* move and link
    - Download the PDF and manually move & link it using right-click --> Manage Attachments --> Rename attached files
  • (You should also revert 6. which isn't needed for what you're trying to set up and could end up causing a bit of weirdness)
  • edited 3 days ago
    @adamsmith Thank you so much, that totally worked! Went back to abstract page and clicked on Zotero Connector and ZotFile even showed a notification saying "New attachment file renamed". Then in Zotero the new item had the PDF as a linked file and the PDF itself is in the MyFolder I specified.

    For anyone with the same issues as me, after setting up Zotero and everything else just as I laid out in my instructions above, you then have to download the PDF through the webpage that *leads* to the PDF file being shown in the PDF viewer in the browser.

    I also reverted step 6 and cleared that space as instructed by @adamsmith .

    One last question if I may. Is there a standard way of knowing when ZotFile will work or do I have to trial and error my way until I get it to work with a certain PDF online/Webpage? (As you said ZotFile can't directly download PDFs, but should work well in every other situation right?)
    I know as a last resort I can always set up the item in Zotero myself, separately download the PDF and move it to MyFolder, and then import it to Zotero as a linked file.

    Again thank you so much!
Sign In or Register to comment.