Error ID: 1032796315

Zotero on my PC (XP) has been having sync errors for the past month. I have turned off automatic sync, but when I do a manual sync, the sync arrow just keeps spinning, and then if I try to access my library it displays the message that an error has occurred (the same thing happens when I turn on auto-sync). If I do a full sync through the reset tab, that does work, although it seems to take a very long time.

After the error occurs, Zotero becomes unusable until I restart Firefox.

I was hoping that the new beta version of Zotero (b4) would solve the problem, but it has not. (I am also running the current version of Firefox -- 3.5.3.)

Any leads?

  • Could you generate debug output for the sync attempt from the Advanced pane of the Zotero prefs, submit it to the server, and post the Debug ID here? Thanks.
  • Okay, the Debug ID is D523134796.


  • There appears to be a problem with the .eco file in the 'storage/58TBZ3SF' directory in your Zotero data directory. Can you take a look at that file and let us know if you notice anything particular about it? (Is it an empty file, is it an alias rather than a regular file, etc.) You could also try temporarily moving the file out of that folder and trying to sync.

    Note, by the way, that this is a file sync problem only, and your metadata sync is still working properly.
  • Great, that solved the problem.

    Let me explain about the .eco file: Once I got my WebDAV file syncing set up about a month ago, it occurred to my that I could use Zotero for other file syncing as well, so, for instance, I began to store my Ecco Pro (which is Personal Information Manager) file in Zotero. That way, I figured, my latest changes in Ecco Pro would regularly be backed up online. This setup seemed to work very well for a while. I have not discovered anything wrong with the file, but perhaps what happened is I tried to edit the file while a sync was running... could that be the issue? I don't know very much about how WebDAV works...

    For now, I just re-saved my Ecco file to my harddrive and deleted the copy from my Zotero library, and now sync seems to be working normally again.

    Thanks again for your help -- and let me know if there's anything else you want me to clarify in order to pinpoint why the error came up.
  • Have you reimported the file back into Zotero? If you do so, does it then sync?
  • Well, just to see what would happen, I reimported the file to Zotero. At first it synced fine. Then I opened the file in Ecco (after locating it via the "Show File" button in Zotero), wrote a new note in Ecco, saved it, and re-synced. This caused the same error as before, so that I have to re-start Zotero.
  • Does this only happen when the file is open in Ecco?
  • Yes, apparently the error only occurs when the file is open in Ecco. When I tried closing the file first, the sync was error-free.

    FYI, Ecco automatically creates temporary files (.bk1 and sometimes .bk2) in whichever folder the main (.eco) file is stored. I wonder if this has something to do with it?

    (I also store my Taskcoach (.tsk) file in Zotero in a similar manner, but it does not create any problems even when I sync while the file is open in Tasckcoach.)
Sign In or Register to comment.