Zotero Connector doesn't work on PDFs

This discussion was created from comments split from: Zotero google extension not working.
  • I am having the same problem. I switched chrome profiles, and now my zotero extension no longer works for clipping articles. It DOES work on amazon, clipping pages. But does not work to clip PDFs. I do a lot of article grabs, and this is a big problem! (this type of clipping used to work for me, two months ago). I have attempted this on 3-4 different sites. This is one example:


    I have tried:
    -uninstalling, reinstalling (no change),
    -uninstalling, restarting computer, reinstallling (no change).
    -trying Zotero on amazon (works for taking snapshot; not pdf capture)

    I am currently running Chrome 97 and version Zotero downloaded last week, so software should be up to date.

    When I hover over the zotero icon, while on the PDF page, I only see the snapshot option. I click it. No response.

    I just tried uninstalling my adobe acrobat extension on Chrome, and I think that solved the problem!
  • @kfehrer: Yes, you weren't viewing the PDFs directly — you were viewing them in the Acrobat extension. (That's the "chrome-extension://efaidnbmnnnibpcajpcglclefindmkaj/viewer.html" part of the above URL.) Zotero can only work on PDFs you view directly (e.g., with an https:// URL).
Sign In or Register to comment.