Problems with "My Publications"

Report ID: 820870404

I cannot add anything to the "My Publications" folder. None of the icons [new item, add item(s)] at the top work when in this folder (they are greyed out) nor can I drag and drop a PDF in this folder.
  • From the intro screen for My Publications:
    To add items, drag them from elsewhere in your library. You’ll be able to choose whether to include attached notes and files.
    You need to drag actual bibliographic items with metadata, not just PDFs.
  • Are you by any chance trying to do that in Web Library, a web based version of Zotero? Currently you need to use Zotero, an application that you download and install on your computer, to add items to "My Publications".
  • I have the same issue. I'm using the desktop version of Zotero, and I am trying to drag an item from my library (not just a pdf, a bibliography entry), and the My Publications collection on the left doesn't light up as I hover over it, And when I go to My Publications, neither the "New Item" nor "Add Item(s) by identifier" buttons do anything when I click them (unlike when I have My Library selected).

    I am signed in, and sync works.
  • @jahoo: Can you provide a Debug ID for trying to drag?
    when I go to My Publications, neither the "New Item" nor "Add Item(s) by identifier" buttons do anything when I click them
    That's by design. You have to drag.
  • Oh, I would, but it started working :). I think the only actions I've taken that might have changed something was that I re-installed the Better BibLaTeX plugin (because I was also getting some odd behaviour there), and restarted Zotero. Now dragging works.
Sign In or Register to comment.