weird library behaviour [report_ID:83022766]

edited December 28, 2021
I tried to move a couple of subcollections via drag 'n' drop.

When I dragged the subcollection A into B, I had a duplicate A* in B.

So I tried deleting A in the previous place.
But instead A* in the "new place" disappeared.

Further, I cannot delete A now.

To add to the confusion, the content of A now is:
Well, ALL entries and items I have in Zotero.
The initial files of A are lost in the ocean, so to speak @_@

I'm not too savvy and I don't know what to make of it...
  • 1) Provide a Report ID.

    2) Before closing Zotero, make a backup of the zotero.sqlite and .bak files in your Zotero data directory.

    3) Restart Zotero and check your database integrity from the Advanced → Files and Folders pane of the Zotero preferences.

    And then restart Zotero again and assess the situation.
  • Thanks for your efforts stillman!

    Upon following the steps:
    the collections are gone, the entries and items are alive.
    Can live with that...
    Was a bug?

    checkhealth says: everything OK

  • OK, so it sounds like you may have hit a visual bug and then deleted the actual collections by accident when you thought you were deleting duplicates.

    Depending on when this happened, you should be able to restore from one of the automatic backups. (By this point, you should try the versions in your backup of that folder.)
Sign In or Register to comment.