Some values missing when exporting items to CSV


I'm trying to export about 300 items to a CSV file. In the output, the value for the "Date" column is missing for about a third of the items. I can't seem to understand why. I also tried exporting a single one of the items with missing date values, and the date is missing here too. All dates do show up in the main Zotero pane and also when generating a report from these items.

Would anyone know how to fix this?

Thanks in advance.
  • What item type? And have you looked at the raw text file to make sure this isn't just a problem of Excel reading the CSV?
  • Newspaper Article. I checked the raw text file -- the date was missing there too.
  • There's nothing in the export script that should prevent this and looks fine for me -- does this happen for all newspaper articles or just for some?
    If just for some, anything particular about the date format in Zotero?
  • Ok I looked a bit closer at some of the exports of items with missing dates. There's text in the Abstract field, and plenty of these texts contain a semicolon or colon. This seems to be messing things up and stopping the program from outputting values in subsequent columns. Not sure how to fix this though...
  • Hmm - I can't replicate this with any combination of colons, semicolons, quotation marks, or commas (nor should those be a problem). Could you export one such item to Zotero RDF (without file attachments obviously) and post the file somewhere we can look at it (, Dropbox, etc.)
  • Sorry, I didn't properly check the raw text the first time. It seems the raw text is OK, so it must be something with Excel. Could it be something to do with the encoding?
  • Solved: importing the CSV data into excel using the "From text" option under the Data tab did the trick.
  • Excel's default CSV import parameters are very odd.
Sign In or Register to comment.