Problem with import of pubmed search results

I have a problem to import some results of a pubmed search. I tried it on mac, windows, chrome, microsoft edge, firefox, with 2 different zotero accounts : it's always the same problem: i can save the 3800 first results of my search but then it won't work anymore (4169 results). Most of the time without any error message : the saving with the list of articles appears in gray then closes without saving any article. When an error message pops it just says that an error occured. Even if i tried to just select one article it won't save it. Here's a link of the search results :"enterococcus"[MeSH+Terms])+AND+(((("drug+resistance"[MeSH+Terms])+AND+((("glycopeptides"[MeSH+Terms])+OR+"teicoplanin"[MeSH+Terms])+OR+"vancomycin"[MeSH+Terms])))+OR+"vancomycin+resistance"[MeSH+Terms])))+OR+"vancomycin+resistant+enterococci"[MeSH+Terms]&filter=dates.1988/1/1-2021/12/1&page=20&size=200
I really can't figure out the problem here if you can help me please. Thank you very much !

Thibaut Goetsch
  • edited December 9, 2021
    Best way to save from PubMed is to (after you have selected the desired items on the PubMed site) click the "send to" button (Save - Email - Send To); from the drop-down, select citation manager; then "create file". This will save your results as an nbib file. Import the nbib file into Zotero by using the import command under the Zotero file menu. Remember to click the "Done" button or it will seem as though Zotero has frozen. This always works perfectly.

    EDIT Do not save your lengthy PubMed results as PMIDs and import them using the Magic Wand. You will have a pattern of similar missing records. This problem is due to an issue with NLM PubMed -- the server there "doesn't like" responding to many requests in rapid sequence from a single IP.
  • Thank you ! I tried but seems like Zotero doesn't support .nbib files and there doesn't seem to be alternative export formats
    Debug ID of the import of nbib : 2132842085
    Debug ID of the import from web page :1616134952
    Thank you for your help !
  • Yes, Zotero supports .nbib files.

    If you're getting an error, we'd want to see a Debug ID of an import attempt that fails. You provided a Report ID.
  • Well this morning import of nbib works perfectly on PC and Mac... Problem solved, thank you anyway !
    Still wondering about the failures of zotero connector to import, here's a Debug ID for this issue : D1686219914
    Thank you very much for your help !
  • I am not a programmer and am new to zotero. Where is the file menu? Trying to import a nbib file to update an article.
  • It's in the top menu, all the way on the left. If you're not seeing a menu (File, Edit, View, Tools, Help), you're likely using the web version of Zotero. You need to have the software installed locally to import from metadata formats like nbib
Sign In or Register to comment.