Selecting PDF in iOS via WebDAV sync results in error

iOS: Zotero 1.0 (168)
macOS: Zotero 5.0.97-beta.56+32a5826a1

First: Thanks so much for adding WebDAV support to iOS client. It is a critical feature and I am glad it has arrived.

For new files this works very well and I was able to work on PDFs on mobile, annotate and those annotations sync back to desktop as expected.

For older files that existed prior to the WebDAV sync setup in iOS I receive the following error when tapping them on mobile:
Error: Linked files are not supported. You can still access them on your desktop client.

That is all nice, but what do I do about this? This error message is not actionable. Someone mentioned transferring old items to some new format, but gave no steps. Could more detail be added to the error message so that users are able to take the required steps so that they can work with the problematic files as well on mobile?
  • They're just linked files rather than stored files. You would've had to go out of your way to create those (either manually or with ZotFile), so it's assumed that you understand the difference. Linked files have never synced via Zotero.

    If you want to convert linked files to stored files, you can do so in the desktop app via Tools → Manage Attachments.
  • edited 12 days ago
    Hey dstillman - thanks for the super quick feedback - much appreciated.

    Sorry, I was not aware of the difference. When I select Tools > Manage Attachments > Convert Linked Files to Stored Files … I am asked if I want to delete original files after storing.

    I assume if I want to go WebDAV, "yes" is the correct answer to that question?
  • It makes no difference to Zotero whether you delete the original, but you generally want to do so — no need for a duplicate copy elsewhere on your computer.
  • edited 12 days ago
    Ok proceeded with the action and ticked checkbox to delete original files. Now all files are available on mobile.

    I can't express how nice it is seeing your work progress and Zotero really becoming usable. The improvements of the past months are huge - great work.
  • Added another PDF and end up with the same error message. I now know which steps to take to resolve this.
    However I would love for any new PDF to be in the correct state to be also editable on iOS. Is there anything I can do to use the correct format right away when adding a PDF to Library?
  • Zotero saves stored files by default. If you're getting linked files, you likely still have ZotFile installed and configured to convert new files to linked files.
  • edited 10 days ago
    Used ZotFile for:

    a) set custom subfolder folder for WebDAV
    b) have files stored in human readable structure in desired format: YYYY Author_Last_Name Title

    a) in zotero I can only use the main folder which is then filled with randomly named zip and prop files. I am sure there are good reasons for this, but I would prefer this in a dedicated zotero folder. Is that somehow possible?
    b) I am fine with giving up on easy direct access to the PDF files with annotations already in them and rename them manually.
  • edited 10 days ago
    There might be some confusion here.

    1) Zotero renames files based on parent item metadata ("[Creator] - [Year] - [Title]") by default.

    2) Make sure you've read through Stored Files and Linked Files to understand how the ways that stored files can be used. For local usage, there's not much downside to using stored files, and a lot of upside, unless you're really committed to manually browsing through filesystem folders instead of just typing a name in a search bar or clicking on a collection or tag.

    3) I don't know what you mean by "I would prefer this in a dedicated zotero folder". .zip and .prop files are just on WebDAV, not your computer, and they're in a dedicated folder on the WebDAV server. The point of using Zotero file syncing is that you can access the files from any Zotero app on any device (e.g., your computer and the iOS app). Unless you really need to access files directly from your WebDAV server outside of Zotero, the contents of that folder shouldn't make a difference.
  • I have now disable ZotFile which I previously used for naming files in the desired format, so

    1) renamed all existing files to follow the default format zotero uses.
    2) without zotfile, zotero now defaults to stored files which is what I need.
    3) For my WebDAV setup I use URL: https cloud.provider.org/remote.php/dav/files and zotero adds "/zotero/ which I cannot edit. This results in all files zotero creates ending up in the top level. Maybe this is due to the webdav username being "zotero". What I want would be the files to be in a zotero subfolder, yet when I enter cloud.provider.org/remote.php/dav/zotero (with the default added /zotero/ at the end), the URL is switched back to the initial format. So it seems I have no way of specifying a folder structure where the zotero files should go.
  • edited 6 days ago
    For my WebDAV setup I use URL: https cloud.provider.org/remote.php/dav/files and zotero adds "/zotero/ which I cannot edit. This results in all files zotero creates ending up in the top level.
    Not sure what you mean by this. The whole point of the hard-coded '/zotero/' is that it ensures the files end up in a 'zotero' subfolder on your WebDAV server. If that's not happening, it's a bug in your WebDAV server.
  • edited 6 days ago
    Entering the URL like this: https://postimg.cc/xqBHnWNj

    results in only this: https://postimg.cc/VdjS15c4

    Maybe this is indeed a bug of the WebDAV server. The webdav store name is also zotero so maybe this is triggering this unexpected behavior.
  • The hard-coded “zotero” is appended to the path, and it won’t let you add a second one because having two “zotero” folders next to each other would generally just be a mistake.

    This doesn’t have anything to do with the username itself, but if you’re saying 1) your WebDAV account is “zotero” (which I’m not sure why you would do) and 2) your WebDAV server requires the username to be part of the path (which isn’t standard) then you’d have to add an extra folder after the first “zotero” if you don’t want the files at the top level.
  • Not sure - it would be a deliberate design choice in my case, but I see where you are coming from. But wouldn't that mean that all files should be in zotero folder? They are not for me as they are on the top level of the WebDAV server. I still believe that is maybe because that network share is called "zotero" itself. In both cases you can argue not to see why that would be a design choice made by a user and yet here I am having consciously and intently made both decisions.

    Anyhow - I created a new folder on the WebDAV called "bib" in the hope that that would allow me to get rid of the zotero files on the top level. But when adding the /bib subfolder to the end of my WebDAV URL: https://postimg.cc/crjmTsRW zotero still complains about https://cloud.provider.org/remote.php/dav/files/bib/ does not exist. And yet it does. So now I am just not sure if this is a bug in zotero, the webserver, an issue with the naming of the webdav server which may confuse zotero and it appears I am stuck with non human readable files on top level.
  • edited 6 days ago
    The whole point here, as I understood it, was that you need to use "remote.php/dav/files/zotero" to reach the top level of your WebDAV files, based on the username you chose. So then if you want to use a subfolder, given that Zotero enforces a single trailing "zotero", you would need to use "remote.php/dav/files/zotero/[some other folder name, like 'bib']/zotero". That's not what you entered.

    In any case, there's no problem with Zotero here. It uses the entered path, with "/zotero" at the end. It's up to you to know what URL you need to use with your WebDAV server. If you're having trouble setting up a WebDAV server, use Zotero Storage, which just works. I'm afraid we can't help further here.
  • edited 6 days ago
    You are perfectly right:
    "cloud.provider.org/remote.php/dav/files/zotero/bib" /zotero/ worked and resulted in what I want. Thanks for helping me figure this out. Adjusted the iOS path as well and I think I now have a working zotero setup.

    Thanks for your quick responses, outstanding support (on a weekend!) and caring about users. Have a great sunday.
Sign In or Register to comment.