Chromebook install not working after powerwash (SOLVED)

edited 17 days ago
So, I had done this twice in the past, easy-peasy, this time no happiness.

I think the problem is that packages need to be updated, but I, pretty much a Linux novice cannot do that. When I tried to update using "sudo apt upgrade zotero" some packages seemed to update, but there was an error message:
---Err:9 https://github.com/retorquere/zotero-deb/releases/download/apt-get ./ zotero 5.0.96.3
401 Unauthorized [IP: 185.199.110.133 443]
Is this the problem? How to fix?
__________________________________

More detail below, if needed
___________________________________

Here are the steps I took.

Followed the directions for installing on chromebook:
------------
Enter these commands in Terminal to install a packaged version of Zotero maintained by a community member:
1-- curl -sL https://github.com/retorquere/zotero-deb/releases/download/apt-get/install.sh | sudo bash
2-- sudo apt update
3-- sudo apt install zotero
----------------
This time, step 2 returned a list of upgradable packages, with this message at the end
--- "9 packages can be upgraded. Run 'apt list --upgradable' to see them." ---

Ignoring that, I went on to step 3 which returned the following:

--- sudo apt install zotero
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
libdbus-glib-1-2
The following NEW packages will be installed:
libdbus-glib-1-2 zotero
0 upgraded, 2 newly installed, 0 to remove and 16 not upgraded.
Need to get 64.2 MB of archives.
After this operation, 211 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 https://deb.debian.org/debian buster/main amd64 libdbus-glib-1-2 amd64 0.110-4 [71.5 kB]
Err:2 https://github.com/retorquere/zotero-deb/releases/download/apt-get ./ zotero 5.0.96.3
401 Unauthorized [IP: 185.199.111.133 443]
Fetched 71.5 kB in 1s (102 kB/s)
E: Failed to fetch https://objects.githubusercontent.com/github-production-release-asset-2e65be/153281752/78217453-f011-4a14-b123-b31c31945350?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A/20211119/us-east-1/s3/aws4_request&X-Amz-Date=20211119T224239Z&X-Amz-Expires=300&X-Amz-Signature=fd58685fe42b9571e8d867af15c0a462b503b2558ded7365a2a89b1b25026644&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=153281752&response-content-disposition=attachment; filename=zotero_5.0.96.3_amd64.deb&response-content-type=application/octet-stream 401 Unauthorized [IP: 185.199.111.133 443]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

So, I tried using script I found online to do the update and it didn't work --- syntax error?

--- sudo apt upgrade zotero
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
libdbus-glib-1-2 zotero
The following packages will be upgraded:
base-files debconf krb5-locales libgssapi-krb5-2 libk5crypto3 libkrb5-3
libkrb5support0 psmisc tzdata
9 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 65.5 MB/65.6 MB of archives.
After this operation, 210 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 https://deb.debian.org/debian buster/main amd64 base-files amd64 10.3+deb10u11 [69.9 kB]
Get:2 https://deb.debian.org/debian buster/main amd64 debconf all 1.5.71+deb10u1 [145 kB]
Get:3 https://deb.debian.org/debian buster/main amd64 tzdata all 2021a-0+deb10u2 [266 kB]
Get:4 https://deb.debian.org/debian buster/main amd64 krb5-locales all 1.17-3+deb10u3 [95.5 kB]
Get:5 https://deb.debian.org/debian buster/main amd64 libgssapi-krb5-2 amd64 1.17-3+deb10u3 [158 kB]
Get:6 https://deb.debian.org/debian buster/main amd64 libkrb5-3 amd64 1.17-3+deb10u3 [370 kB]
Get:7 https://deb.debian.org/debian buster/main amd64 libkrb5support0 amd64 1.17-3+deb10u3 [65.8 kB]
Get:8 https://deb.debian.org/debian buster/main amd64 libk5crypto3 amd64 1.17-3+deb10u3 [122 kB]
Get:10 https://deb.debian.org/debian buster/main amd64 psmisc amd64 23.2-1+deb10u1 [126 kB]
Err:9 https://github.com/retorquere/zotero-deb/releases/download/apt-get ./ zotero 5.0.96.3
401 Unauthorized [IP: 185.199.110.133 443]
Fetched 1,418 kB in 1s (1,831 kB/s)
E: Failed to fetch https://objects.githubusercontent.com/github-production-release-asset-2e65be/153281752/78217453-f011-4a14-b123-b31c31945350?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A/20211120/us-east-1/s3/aws4_request&X-Amz-Date=20211120T154358Z&X-Amz-Expires=300&X-Amz-Signature=af2cc4af0cdb87eee3e0c1ac577931ce2a6a2a7129f0e8e5e2d9da2a77d0e5bc&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=153281752&response-content-disposition=attachment; filename=zotero_5.0.96.3_amd64.deb&response-content-type=application/octet-stream 401 Unauthorized [IP: 185.199.110.133 443]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?



  • Ok. Found a fix. The old link is broken. Try again with these commands

    wget -qO- https://downloads.sourceforge.net/project/zotero-deb/install.sh | sudo bash
    sudo apt update
    sudo apt install zotero
  • The old links aren't broken, apt is broken and flakes out on the new (valid and working) urls github releases now use. A ppa fix for apt is available, but that doesn't work on every system, so the sourceforge mirror can be used as a workaround.

    I'll likely just keep the sourceforge mirror going, since it's no effort to maintain it, but I dislike sourceforge, and github releases will remain the primary release channel for the debs.
Sign In or Register to comment.