ODF Scan not working on Scrivener-LibreOffice connector - beta

Hello! I am using the Zotero beta for iOS as well as the desktop version on my Macbook and drafting in Scrivener. I am now trying to export my Scrivener draft to LibreOffice with citations. Once I've exported my Scrivener document as an odt I'm trying to run the ODF scan to create a citations version of the doc that I can then open in LibreOffice.

I'm having two different problems - with some documents Zotero simply says the document can't be processed, and other times it runs the scan but then the citations file I open in Libre Office doesn't have live citations in it so I can't create a bibliography.

Is this due to me using the beta or am I doing something wrong?


  • You're using the ODF citation markers that look like this?
    { | Smith, (2012) | | |zu:2433:WQVBH98K}
    As far as I know, ODF scan should work in the current beta.
  • Yes that's right. I've just exported the document to word and tried there - it says it can't communicate with Zotero even though Zotero is clearly open. I wonder if the problem is that for a while I had two versions of Zotero running - the normal one and the beta - and the plugin is looking for the normal one? Is there a way for me to reinstall the Word or LibreOffice plugins, or do I need to uninstall and reinstall Zotero to do that?
  • OK I've tried reinstalling the beta on my Mac but nothing has changed. I deleted the LibreOffice extension but it hasn't reinstalled it on opening Zotero. I looked in the Cite bit of Preferences but neither the plugins is visible in the Word Processor section, and the Add-On option isn't on the Tools menu any more. I'm very confused!
Sign In or Register to comment.