iOS: WebDAV verification still fails (build 166)

Entering credentials which are the same as on the desktop version don't work. The WebDAV server is Seafile over https (Apache2), and sync is working on the desktop.

When I click the "Verify Server" button in the sync settings for the app, I get the message "The operation couldn't be completed. (Zotero.AFResponseError error 1.)".

Debug ID D614792749.
  • Try the latest build.
  • 167, same problem still exist with self-hosted Seafile. Debug ID D38315522
  • edited 15 days ago
    412 Precondition Failed: If-None-Match header condition failed
    We'll look into this.
  • I still get the same error with 167. Debug ID D2146701573.
  • @pboley, @LadderOperator: Can you provide a Debug ID for verifying the same Seafile server from the desktop app?
  • D1154088057
  • Thanks. And can you provide a Debug ID for Verify Server on iOS immediately after verifying successfully on the desktop? Make sure it's the first attempt on iOS after it completes on the desktop.
  • D1638801791

    I enabled debugging after next launch in iOS, force closed the app, verified on the desktop (it works), launched the app in iOS, verified (doesn't work, same Zotero.AFResponseError error 1). While this was happening, in the lower left Zotero writes "Sync failed (Remote sync in progress. Please try again in a few minutes."

    Just to be certain, I closed Zotero on the desktop, and it still writes "Sync failed" (and fails to verify the WebDAV.
  • Thanks — this should be fixed in the latest build.
  • edited 15 days ago
    Yes, I confirm that with build 168 the credential verification works.
    Thanks!
  • Yes, it's also working for me now. Thanks!
  • WebDAV worked for me with build 165, but server verification fails with all subsequent builds.
  • Same issue as mainland. 4shared WebDAV is not working.
  • @mainland, @ftaberner: We'd need Debug IDs for Verify Server to say more. Make sure you're running the latest build.
  • edited 14 days ago
    Here comes mine D992267931
    Files do not sync in this build (168)
  • edited 14 days ago
    (+0000348): HTTP PUT https://webdav.4shared.com/zotero/zotero-test-file.prop succeeded with 200

    (+0000008): HTTP GET https://webdav.4shared.com/zotero/zotero-test-file.prop

    (+0000200): HTTP GET https://webdav.4shared.com/zotero/zotero-test-file.prop succeeded with 404

    [ERROR] Zotero(+0000005): WebDavController: checkServer failed - fileMissingAfterUpload
    @ftaberner: You're using a WebDAV server that doesn't make files immediately available after they're uploaded. There's a warning in the desktop app when this happens, and it should be a warning in the iOS app as well, but it's possible it's getting turned into a fatal error instead. @michalrentka will need to look into it.
  • Pcloud (us) webdav not working too, here is mine too D2020962214
  • @kamarianakis: It looks like the "zotero" folder doesn't yet exist at the location you specified. It should prompt you to create that, as in the desktop app, but it's possible that's not working right on iOS at the moment — we'll look into that. If you create the "zotero" folder manually, it should work. (But if you're already using WebDAV in the desktop app, the folder would exist, so if that's the case you either entered the wrong URL or there's something wrong with your WebDAV server.)
  • yes, creating the zotero folder seemed to fix it. So, for the record, iOS does not support creating the folder or prompting to create it, so it should be taken into consideration by the user beforehand. many thanks!
Sign In or Register to comment.