Error problem when adding rich formatting to titles

edited 19 days ago
I have tried adding rich formatting to some titles, and the italic works, but when I try with <sup> and </sup> for superscript, it creates a bug in my word document, I cannot refresh nor add citations, unless I erase the superscript indications in my Zotero library.
I use an edited version of the style Université Laval - Département des sciences historiques
  • Can you reproduce this with a minimal document with just one item?
  • No it gives me the same error message
  • I can add the citation with the superscript, but once it's in my document, I try to refresh or add a citation or a bibliography the error message appears
  • Any idea?
  • Please exactly quote the error message. This may help the experts here identify the problem. If the error is not English do not translate it.
  • It reads "Zotero a rencontré une erreur lors de la mise à jour de votre document. Souhaitez-vous afficher les instructions de dépannage? -oui-non"
    And it leads me to the general debugging page of Zotero : https://www.zotero.org/support/kb/debugging_broken_documents
  • You said "no" when adamsmith asked if you can reproduce this with one item. Did you mean yes?

    The debugging page you linked to explains what we'd need to debug this — specifically, a document excerpt that reproduces the problem, and a Report ID.
  • Report ID : 735763965
  • [JavaScript Error: "state.fun.decorate[params[0]][params[1]] is undefined" {file: "chrome://zotero/content/xpcom/citeproc.js" line: 5522}]
    We'll also need the document excerpt and a copy of the style you're using.

    Does this happen with a non-custom style?
  • Here's a copy of the style I use: https://pastebin.com/pGBiq6Fp
    I tried it with another style and it worked just fine.
    I'm not so sure how to give you the document excerpt though.
  • You should also send the document excerpt from Step 10 and a link to your forum thread to support@zotero.org so that we can try to reproduce the problem.
Sign In or Register to comment.