Ctrl+Shift+C acting like Ctrl+Shift+A

Recently (last few days at least), the keyboard shortcut Ctrl+Shift+C (Copy Bibliography) has been behaving like Ctrl+Shift+A (Copy Citation) when pasting into PowerPoint or Word. It works fine clicking from the Edit menu, but the shortcut keys aren't working. Anyone know what happened or how to fix it?

Note: I'm still on ver 5.0.96.2 because our company hasn't pushed the last couple of updates yet. (Windows 10 Pro ver 1703 OS Build 15063.1563)
  • You've checked in the shortcut menu in the preferences that they haven't been changed?

    Which citation style do you have set for quick copy in the Export tab of the preferences?
  • The preferences still shows Ctrl+Shift+C for "Copy Selected Items to Clipboard". None of the others uses the C.

    Citation style is American Medical Association 11th edition.
  • And that's just copying superscript numbers?
  • edited November 16, 2021
    Yes. If I use the keyboard shortcut I just get the superscript 1 when I paste in the target document. If I click into the Edit menu and click Copy Bibliography from the menu, it works properly, pasting in the whole bibliography entry.

    If it's helpful, I'm using Office Version 2110, build 14527.20234 (Office 365 business desktop apps)
  • Can you provide a Debug ID for pressing Ctrl-Shift-C?
  • Keyboard shortcut: copySelectedItemsToClipboard
    That certainly should be copying references, not citations.

    Can you copy some other text to the clipboard, paste that, and then confirm that a new attempt still gets you the citations?
  • You mean other text, like copy from Word to PowerPoint, or other text from Zotero, like copying a title from the info fields?
  • Doesn't matter. I just mean to clear the clipboard.
  • I just did both - copy-paste from Word and another field in Zotero into PPT - both worked as expected. I retried the keyboard shortcut to copy-paste from the center pane selection into PPT and I still get the citation instead of the bibliography.

    (I would like to update but I'm dependent upon my IT dept to allow it and haven't been able to get that done yet. I will continue to prompt the update, but for now I've got the version I've got.)
  • OK. No particular reason to think the version matters, but I'm afraid we can't really debug this further until you're on a current version.

    You can try some other things to see if it helps — restart Zotero (which I assume you've done), try a different style, reset styles from the Advanced → Files and Folders pane of the Zotero preferences. Beyond that, you'll need to use the menu option until you're able to upgrade and test further.
  • I'm not sure what fixed it, but it seems to be working properly again. I appreciate your time on this. Thanks!
Sign In or Register to comment.