Problem with accentuation and cedilla in notes


The notes field does not recognize accentuation characters such as "á "or cedilla "ç" (examples: "O dia est’ lindo", "corac’ao"; it should be "O dia está lindo", "coração") in notes, but it does recognize them in the comments field on annotations.

Any clues on how to solve this?

I am using a Mac.
  • What do you mean by "does not recognize"? Zotero notes fully support Unicode.
  • For instance, I press "'" followed by "c" on notes and it does not recognize as "ç" (like it worked here now), although in comments it recognizes.
  • edited November 12, 2021
    I'm not sure what method you're referring to.

    On a Mac you can get a cedilla by pressing Option-C. Newer macOS versions introduced a way to do that by pressing and holding the letter key itself — I'm not sure off-hand (and can't test at the moment) if that works in the new note editor.

    I'm not aware of any built-in method that works like you're describing. The note editor isn't a standard text field, though, so it's not unexpected that something might not work there. The Option-based combinations will always work everywhere.
  • I'm facing the same issue as @hestellita .

    I tried the keyboard configuration "Brasileiro - Pro" in my mac and it had the exact same behaviour as described: when trying to use accentuation in the normal path for the Macbook Pro keyboard (keystroke for < " and ' >, then the desired vowel key for accentuation or < C > for cedilla) it doesn't work. In some cases, with a specific timing stroking both keys, it worked, but it's not the expected for this keyboard.

    Then I tried using the ABNT configuration and it worked normally as expected. This makes me think this issue is related to a bad configuration of the Macbook Pro keyboard in Zotero.
Sign In or Register to comment.