PDF reader - had to be 'activitated' for first time use (preference didn't work)

Like many, I had to abandon Mendeley. I am very thankful that Zotero implemented an import function! After installing the latest Windows beta (5.0.97-beta.53) I ran the import. The folder structure, ~2200 references, tags, notes, highlighting, and PDFs seemed to have all come across cleanly. The import even consolidated data from duplicates in Mendeley I didn't know I had into one document (well done!).

I wanted to verify they that my highlights survived the import. I enabled the Zotero PDF reader in preferences, but double-clicking a title or the PDF icon below it was still opening PDFs in Acrobat Pro DC (the system default). Restarting the app didn't help. By accident, I found "View PDF" in the context menu after right-clicking a title. I clicked it and Voila! the doc opened in a tab within Zotero:-)

I only had to do that trick once to 'activate' the PDF reader - now double-clicking works.
  • edited November 11, 2021

    Since my Zotero in VMware is broken, I'm using it from another Windows machine (same exact build #). After upgrading to 5.0.97-beta.55, invoking the PDF viewer worked once but then quit for good. I disabled and enabled it, but no dice. All PDFs are opening in Acrobat Pro DC.
  • @dstillman or @adamsmith -- need a little help here...
  • edited November 11, 2021
    Please don't tag people for random issues. People will read your thread when they want to and respond if they have something relevant to say. adamsmith is a volunteer who has nothing to do with this issue.
  • @cbell4444: If you return to the General preferences after restarting Zotero, is the beta pref still enabled?

    No one else has reported this in the entire beta period, so this is pretty weird.

    Can you provide a Debug ID for double-clicking a PDF and having it open externally while that pref is enabled?
  • edited November 12, 2021
    @dstillman Yes, the pref is still enabled.

    1) Debug ID D671396320 for right-clicking an article's PDF icon and clicking "View PDF".
    2) Debug ID D2110879832 for double-clicking the same article's title.

    Didn't know if these two went through different code paths...
  • As it says in the prefs, the new PDF reader is restricted to My Library during the beta.
  • A newb mistake! ::extreme chagrin:: I was testing the idea of a group and duplicated a folder there. The group folder was selected, but I scrolled up to the same spot in My Library and thought I was working from its folder. Sorry to waste your time.
Sign In or Register to comment.