Sync in Zotero ios beta

I keep having trouble syncing - Debug ID D1850196778. I get the error message Sync failed (Failed API response: No response). Any ways to resolve this?
  • Same issue here, Debug ID: D811050978
  • Hi, thanks for reporting the issue. Based on your logs it seems like there's problem while processing a file for upload.

    @kaulpragya you added an item with attachment named: "Safari - Jul 29, 2021 at 6_18 PM.pdf". Do you still have that file? Would you be willing to send it to us for debugging?

    @smatter same question for you, but the name is: "(The Lewis Henry Morgan Lectures) James Ferguson - Give a Man a Fish_ Reflections on the New Politics of Distribution-Duke University Press Books (2015).pdf".
  • Sure, I can send the file @michalrentka can you tell me where to send it please? Couldn’t find an email address on very quick look in the app and doc page
  • @smatter my bad, please send it to Thanks!
  • This is fixed for me now. (got my laptop back from repair today, so was able to try a thing).

    Steps I took to fix it:
    1. On desktop, found that attachment was also producing an error when trying to open within Zotero.
    2. Deleted the attachment that was causing problems,
    3. Renamed and reattached the file.
    4. Success.

    5. Then on iOS beta, tried to sync., but still received error message
    6. Deleted the attachment from iOS beta, then synced again Still getting error message, but saw renamed file as attachment.
    7. Tried one more sync, but still got error message.
    8. Deleted iOS beta app and data
    9. Reinstalled iOS beta app from Testflight
    10. Opened, logged in, synced
    11. Success.

    Wondering if the source problem had to do with the filename for the attachment? There were two sets of parentheses in the filename, and those are removed from the renamed filename.

    Anyways, back to happy Zoteroing for me! Thanks!
  • I got it fixed as well using your example.

    I deleted the problematic file, deleted and re-downloaded Zotero iOS beta app, and then things seemed to be syncing again. Thank you for your help!
Sign In or Register to comment.