Unable to access group library through the Zotero app (but works in the browser)

Hi all!

I have a shared group library that I am able to see through my Zotero account through the browser, however, through the Zotero app, I am only to see a very limited amount of the folders. I have tried to uninstall and re-install the app, and also tried to sync various times.

I would appreciate it if anyone has any suggestions or solutions.
  • Thanks, dstillman. I work with sarahmalykke and she is still facing this problem, even after checking all the troubleshooting options on that "Changes Not Syncing" page. We have confirmed that her app (thinks that it) is syncing. And, in fact, some newer collections that I have made (as admin) now appear on her app...but some older collections still do not appear for her. We have also tried "Restart with logging enabled" as that seemed to help another user with a similar problem, but to no avail for sarahmalykke. In essence, it seems that certain collections are "hidden" from her. She has additionally uninstalled and re-installed. Are there other options we can try to get resolve this error?
  • edited March 21, 2022
    The linked page explains what we need to debug this further. (And logging doesn't fix anything on its own — it's just to provide us with more information.)
  • Tried debugging and submitting the output. This is my Debug ID: D1406691041
  • Hi dstillman! I just wanted to follow up to see if the debug from sarahmalykke was helpful in finding the cause of her problem? Thank you!
  • @sarahmalykke: Sorry for missing this. Try this:

    1) Go to your Zotero data directory and make a backup of zotero.sqlite (e.g., on your desktop).

    2) Select the library in the left-hand pane, go to Tools → Run JavaScript, and run the following code:

    var library = Zotero.Libraries.get(ZoteroPane.getSelectedLibraryID()); library.libraryVersion = -1; await library.saveTx();

    3) Perform a normal sync.

    Let us know if that brings the library in sync. If so, you can delete the backup copy of zotero.sqlite.
  • Thank you so much @dstillman It worked!
Sign In or Register to comment.