Broken word document

Hi, I am having persistent problems with inserting citations (in footnotes) in word. It seems to work a bit then it stops working and displays

"Zotero experienced an error updating your document.
Would you like to view troubleshooting instructions?"

I have tried troubleshooting. Zotero and Word are both updated. I've copied the document to a new one. I removed track changes and approved all changes I tried to delete parts of the document but this didn't seem to provide a good answer as to what was wrong as behaviour continued to be erratic.

I'm using Mac Big Sur 11.6
Word for Mac 16.54
Zotero 5.0.97-beta.52+59455ebfa
Many thanks
  • Can you provide a Report ID to start?

    The troubleshooting steps explain how to cut down the document quickly to isolate a problematic section. If you can reliably reproduce the problem with a specific section of the document, send it to with a link to this thread.
  • 827767279.
    I will send you the document.
    Thank you
  • edited November 2, 2021
  • I have tested the document you have sent us and I managed to insert citations into it. Restart your computer and try again. If it still fails in that document, please provide the exact steps on how you're trying to insert the citation and how it fails.
  • Thank you. The problem is that it's inconsistent. I've also continued to work with the document. Sometimes I can insert a citation, and sometime I can't. I haven't figured out the logic. You have the log, right? You can see that I tried and it threw an error messages. I will try to restart
  • Unless you can figure out a way to reproduce the issue consistently we won't be able to fix this. I do recommend cleaning up any "{Citation}" text leftover from previous failed insertions from Zotero, which may cause some issues.
  • I have been struggling with this issue of "Track changes" in LibreOffice writer. When editing a citation with "Track changes" "on" the writer almost always crashes.

    I saw this on Zotero's troubleshooting pages:

    "If Track Changes is enabled when you insert or modify a Zotero citation, it may mark many or all of the Zotero citations in your document as changed or cause field codes to be displayed. On rare occasions, Track Changes may cause Zotero to think a citation is corrupted."

    This only happens on older documents - even cut down to one line and one footnote/citation. It hardly ever happens on new documents. However, that doesn't help me because I need to work on an old document. My only solution is to leave "Track changes" "off."

    I think Zotero documentation should point out this problem more prominently since it is quite serious.
Sign In or Register to comment.