Zotero iOS not saving author names

Hi, I am testing the iOS beta, I’ve found that sending a paper from safari to Zotero doesn’t populate the metadata. Eg sending the paper below to Zotero gives me a reference with nothing in the authors field.

I’m also not sure how to attach pdfs on iOS, even if I load the paper below through my uni proxy the pdf doesn’t copy across to Zotero. If I open the pdf and share it that will send the pdf without any metadata for the reference.

  • That page saves fine for me. Make sure it actually says "Saving with ScienceDirect" during the save and shows a journal article icon. If it shows a webpage icon, you're just going to get an empty webpage item.

    Try again and let us know what happens.
  • Thanks, I tried it again and it worked fine! Not sure what I did wrong.

    Also most of the time the iOS makes me login to the app when I open it, it doesn’t seem to remember my account. Is it meant to do this?
  • You should never have to log in unless you log out or you remove the key for that device from your Zotero account settings.

    I wouldn't think this would cause it, but are you by any chance out of storage space on the device?

    Beyond that, @michalrentka might have some other ideas.
  • No I’m not running out of storage, I have over 100 gb free. I just tried signing out of my account in the app, was going to try signing out and back in. But the app crashed when i tapped sign out.

    I submitted the crash log, see 339399172

    Hope this helps.
  • @ben_a sorry for not coming back to you. Does this issue still occur?

    Does the app update or crash before it logs you out? Do you see any message when it logs you out? Does this happen when you switch between apps or only after some longer period of time?
  • So the first problem seems to have stopped - where every time I opened the app I had to login to my account.

    The second problem is still there - if I go into my account and tap sign out it crashes straight to the homescreen. Then a message pops up saying Zotero crashed and do I want to send a crash log.

    It’s fine for me now because I can use the app properly but still a bug worth exploring.
  • @ben_a are you on the latest build (159)? The logout crash issue was known in 153 and is fixed now. If you still experience it on latest build let me know.
  • Right, no I wasn’t on the latest build, sorry. I updated and it’s not crashing now. It synced my 5,800 entries really fast too which is nice.

    Thanks for your help!
Sign In or Register to comment.