Can't whitelist a self-signed certificate for WebDAV

I've been using Zotero on multiple Windows machines for about a year now (2xWin10, 1xWin8), the library is stored on my home server with a self-signed certificate. The certificate was whitelisted as described here:
Now I can't sync my library anymore due to an invalid security certificate (Error code: SEC_ERROR_UNKNOWN_ISSUER).
I tried to make a new certificate, added it to the exceptions in Firefox and then updated cert_override.txt in the Zotero profile directory -- no difference.

I was thinking it could be due to some recent software updates but it affected all the devices where Zotero is installed, even an older Win8 PC that had no updates for quite some time. Also, no changes on the server were made.

The only other thing I could think of is that I installed Zotero on one more PC where it synchronized everything or almost everything and immediately showed the same error. It was the first instance when I spotted the problem and then I had it on other machines. IS there a limit to the number of devices using the same Zotero account?

I would appreciate any ideas how this issue can be resolved.
  • Hi again,
    No thoughts at all?
  • Nothing has changed in this regard in years. I haven't tested lately, but it's possible you have to generate the override file from Firefox 60 ESR, not a newer Firefox version (similar to the instructions for a custom CA on that page). If you have a cert_override.txt file from another computer that's already working, you should just copy that in. If one stopped working, presumably your self-signed cert changed, and you need to regenerate with an appropriate version of Firefox.
  • It worked with a cert_override.txt genereated in Firefox 60esr!
    Funnily, I didn't update cert_override.txt before the probem appeared. It just suddenly stopped working on all my PCs.

    Thanks a lot!
  • That would’ve just been due to the certificate itself changing, not the override files.
Sign In or Register to comment.