iOS Beta: issues with multiple dots and/or "@" in filenames

On the iOS Beta, I'm regularly running in problems with attaching files to Zotero items whose filename has more than one dot and/or an "@" in it (typically, Journal Papers where a download from the Journal results in a filename like `10.323@j.derer.dab.pdf`, e.g. based on the doi, which is quite common). After attaching it to a Zotero item, the upload of the file and thus the sync of the attachment will often (but not always) fail.

Once this failure to sync the attachment happens, there is no way to restore proper syncing. Removing the attachment from Zotero doesn't work, I must completely delete the App and reinstall to recoved from that error.

N.B.: I tried to capture it in a log, but after I had a failure w/ logging disabled, further attempts w/ logging enabled mysteriously worked w/o issue (speak of demo effect ...). If I manage to capture a failure in a log again, I'll post the Debug ID here.
  • edited 17 days ago
    Can you provide exact steps to reproduce this, with an example?
Sign In or Register to comment.