Deleting Group

My storage has almost reached maximum capacity, so I've been trying to delete groups that I'm the owner of to free up space. For the past three days, whenever I try to delete the groups I get the following message:

Oops! We had a little trouble getting that page for you. Please try again in a minute or two. Our apologies for the inconvenience.

Is anyone else experiencing this problem? I've been trying for several days and it's still not working.
  • edited 21 days ago
    There's currently an issue with deleting some groups. We hope to have a fix next week.

    In the meantime, you should be able to just delete the items in the group, empty the trash, and sync.
  • I can´t delete a group and also that it doesn´t matter if I delete all items in the group, it continue counting those in the total storage count!
  • did you empty the group trash?
  • I'm having the same issue. I am trying to delete a group (I'm the owner and sole member in the group). But I get the same error message as @jgorenberg
  • Deleting groups should now be fixed. Sorry for the delay.
Sign In or Register to comment.