default icons not installed Ubuntu 20.04

So I've never been really happy with the install process for Zotero. I installed it, but the automagic updating process never worked, requiring a manual re-install each time.

Even after the manual reinstall, the icons that show up (when I start typing "Zotero" in launcher, and as an icon on my toolbar) didn't show up. So I had to modify the .desktop file to add

Icon=/opt/zotero/chrome/icons/default/default256.png

That worked. I finally decided to reinstall Zotero (properly I hope) so I deleted all earlier versions and reinstalled the latest (5.0.96.3). Works fine, but now there are no subdirectories of zotero/icons. There is only a file: updater.png.

In the grand sense, the fact that Zotero now has ugly default non-zotero icons doesn't matter. But still, where did the icon files go? Why didn't they extract from the zip file as they did in the past.

Thanks...
  • Linux installation instructions are here:

    https://www.zotero.org/support/installation#linux

    There's no need to edit the desktop file yourself — the set_launcher_script does that for you based on the current path of the folder.

    The icons definitely still exist in the tarball, so I don't know what you're referring to here.

    The updater will work as long as your current user has write privileges to the folder where you extracted the files.

    All in all, if you're having trouble using the tarball, you should use the zotero-deb package as recommended there.
  • First, thanks very much for the help.

    I used find to find any .png files around. They were in Chrome/icons, not icons. Ok. So I had zotero desktop files in usr/share/applications and ~./local. Deleted them both. Ran the set_launcher app and ran the sym link command (on the zotero install page). Failed to get a workable link. Copied my zotero.desktop file to the /usr/share/applications directory and finally I have a working solution. The app works. The icon shows up.

    Not sure why the symlink command didn't give me a useable zotero link.

Sign In or Register to comment.