Different EBSCO titles downloading the same PDF over and over

We have come across an annoying glitch in downloading records to Zotero from our Ebsco databases, of which Columbia University has several.

We first encountered this using Music Index with Full text, but went back and confirmed that the same problem is happening in Historical Abstracts with Full Text, and presumably with all the Ebsco products.   Because these databases are an important part of our information system, we need to try to resolve the problem.  We always urge our users to use Zotero, but downloads from a frequently used resource do not work, those user are likely to become discouraged and stop using Zotero.

The problem is as follows:

After doing a search and retrieving records, users have, as you well know, two ways of retrieving citations and attached full text.

1) When viewing a list of hits, they can click on a folder icon at the top of the screen and then select a few records from a pop-up Zotero list to download.  In this mode, everything works fine.  The only slight peculiarity is that even if a record does not have a pdf attached, the processing report indicates that a pdf is being downloaded but then crosses out the pdf icon.

2) Because the pop-up list of titles and even the short list of records on the screen often have too little information to enable users to decide whether or not to download particular citations, many users prefer to browse item by item through the full record display.  This is where we are experiencing the problem.  Once a record with a pdf is attached has been downloaded, subsequent downloaded records for items without an attached pdf (almost always) have a copy of that earlier pdf attached, totally inappropriately, to the new record. The problem ends when a new record for an item with an attached pdf is downloaded, but it resumes again as soon as another record without an attached pdf is downloaded.  Users, if and when they realize what is happening, need to go back and delete the incorrectly attached pdfs.  To make matters worse, it appears that every now and then the correct text is actually appended even if the Ebsco record does not itself include one.  I suspect that Ebsco is searching, though not very effectively, to see if there is full text for the item somewhere else in our collections.

We brought this problem to Ebsco, but their support team insists that the problem lies with Zotero. I couldn't tell whether this is a translator issue or not at all since I'm not very familiar with those, never having made one.
  • edited 22 days ago
    Seeing the same here (I'm also seeing PDF attachments broken when looking directly at the view that displays the PDF in an iframe).

    EBSCO is right, this is almost certainly a Zotero translator issue -- issue created here: https://github.com/zotero/translators/issues/2717
  • edited 11 days ago
    Just pushed a fix for this issue. Your Zotero translators should auto-update within 24 hours, or you can update manually by clicking Update Translators in the Advanced pane of the Zotero Connector preferences. Please let me know if everything is working as expected on your end now!
  • I just checked it out with a search of Historical Abstracts, and things are working now. Thanks so much on behalf of all the online researchers at Columbia for the speedy resolution of this issue!
Sign In or Register to comment.