How can I change Author/Author/Author to Author et al.?

Hey there,

I am writing my master thesis and I am citing with footnotes in this style BetriebswirtschaftlicheForschungundPraxis(BFuP),1. Auflage.

Now I want the citation to only list the first author plus et al. if there are more than three.
I downloaded the style and opened it (on my Mac) but couldn't find the et-al part.....
So my question: Can I change this and how?

I also would like to have a dot after every citation in the footnotes. How do I do that?

Thanks a lot in advance!
Best,
Vincent
  • PS: It would also be great if someone could tell me how to make the authors' names appear in italic :)
  • You’ve got a few changes you want to make. Could you give an example citation as it appears now and what you want it to look like?
  • Hey there,

    thanks for your reply!
    So this is How the citation appears:
    Ahmad/Mukaddes/Rashed/Samad (2010), S. 63

    And this is how I'd like to have it:
    Ahmad et al.* (2010), S. 63.

    *= Author et al. should be in italic, if more than two authors
    Would also be nice if I could set the dot at the end of every citation as the default.

    Let me know if you need any more information :)
  • Find
    <macro name="author-short">
    <names variable="author" delimiter=";">
    <name form="short" delimiter="/" delimiter-precedes-last="never" initialize-with=". " sort-separator=","/>
    <substitute>
    <names variable="editor"/>
    <text variable="title"/>
    </substitute>
    </names>
    </macro>


    Change to

    <macro name="author-short">
    <names variable="author" delimiter=";">
    <name form="short" delimiter="/" delimiter-precedes-last="never" initialize-with=". " sort-separator="," et-al-min="3" et-al-use-first="1"/>
    <et-al font-style="italic"/>
    <substitute>
    <names variable="editor"/>
    <text variable="title"/>
    </substitute>
    </names>
    </macro>


    For the period, change
    <layout delimiter="; ">
    to
    <layout delimiter="; " suffix=".">
  • Hey there,

    thanks a lot, you're a star! I made the changes and all worked out :-)
    Just one more thing: now et al. is in italics but I also want the authors to be written in italics.....
    How can I do that?
  • oh, sorry, I misread that part
    <text macro="author-short"/>

    -->
    <text macro="author-short" font-style="italic"/>

    You can delete this line again -- it only applies the italics to et al
    <et-al font-style="italic"/>
  • Okay, cool, thanks a lot!
  • I have one last question (hopefully ;-)):
    How can I change the style, so it always shows the URL in the bibliography if filled in?
    My professor requires me to do so, if the source is available for free online.....
    Thanks!
  • <text variable="URL"/> is what you'd need to add where you want it.
  • You may also need to check the include URL box in the cite-->styles tab of the Zotero preferences
  • Thank you, where exactly do I need to add it? Could you tell me between which codes it needs to be put?
Sign In or Register to comment.