Problems with Google Docs Plugin


I originally tried linking my academic Google account to the Connector Plugin (Firefox, most current version) but I wasn't even able to be redirected before an error popped up (400, I believe). I disabled my privacy add-ons and tried again, to no avail receiving the same error. I linked a different account (a normal Google account), and while it accepted the login credentials I either receive 'Zotero is unable to update the document,' 'Please wait while Zotero updates your document' for over an hour, or the buttons on the UI do not respond at all when clicked.

Does anyone know what is up or how to fix this issue? Is it related to the new update?
Any information that anyone can provide on this issue would be much appreciated.

Additional Information:
- Zotero is up-to-date
- Firefox is up-to-date
- Windows 10 may be a build behind (I will be trying any updates here next)
- Academic Google sign-on is done through a redirect to another sign-on page
- Documents I tried have no current citations (one blank and one just notes)
  • You just need to choose the Google account you used to create the document you're editing — that's it.
Sign In or Register to comment.