Trouble with date ranges

Trying to use date ranges in Zotero, for a multi-volume work.

I’ve tried ‘issued’ ranges in Extra field, eg ‘Issued: 1927/1931’. But this isn’t working. Tried, in various combinations: lowercase and capital ‘i’, space and no space after colon, hyphen (-) and forward slash (/) between ranges, full dates and years.

Certain I have got this to work before… What am I doing wrong here?
  • Issued: 1927/1931
    in Extra (make sure it's at the beginning of a line) should definitely work and does for me.

    Which citation style, which Zotero version, and how are you testing this?
  • edited 7 days ago
    Thanks for this. I'm using Oxford University Press (full note), but also tested on Chicago Manual, 17th edn. Checked both styles are up-to-date versions from the repository. Using latest edition of Zotero 5.0.96.3

    Entry:

    Item Type: Book
    Author: Shaw, Napier
    Title: Manual of Meteorology
    Place: Cambridge
    Publisher: Cambridge University Press
    Short Title: Manual
    Extra: Issued: 1927/1931

    Preferences>Cite>Styles>Style Preview... produces, eg. under Chicago 17th (full note):

    Shaw, Napier. Manual of Meteorology. Cambridge: Cambridge University Press, n.d.

    Checked no spaces have snuck in at start of fields.
  • This was solved by deleting Better Bibtex. Not sure why.
Sign In or Register to comment.