Sync not working 2.0b7.2 (Windows and OS X)

I have read that the Windows version of this should have been fixed in 2.0b7.2:

yet I still get this error on my Windows (Vista 64 bit Business, Firefox 3.5.3) system.
Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIFile.create]
[ Repot # 667771593 ]

I also get a sync error on my OS X (10.4, Firefox 3.5.3) system:
Unexpected file upload status 409 in Zotero.Sync.Storage._onUploadComplete()
[ Report # 153487165 ]

Both systems are using Zotero v 2.0b7.2
  • For the NS_ERROR_FILE_NOT_FOUND error, generate debug output for the sync attempt from the Advanced pane of the Zotero prefs, submit it to the server, and post the Debug ID here. Thanks.

    For the 409 error, I assume this is WebDAV? That's a "Conflict" error, which might indicate that you're over your WebDAV quota (though it shouldn't really). If you look in the debug output you might see the actual error message from the server.
  • Windows:
    DebugID = D1731118832

    OS X:
    DebugID = D524047529

    Syncing with WebDAV (from I'm only using 203 MB currently of 1 GB.
    I'm not sure what to make of the debug output, nothing stands out to me as particularly telling, but I'm also not sure what to look for. The error does seem to occur on the first PUT command.
  • For the 409, you'll need to check with what reasons they'd reply with a 409 HTTP status code. (It's an HTTP status code meaning "Conflict", but it's up to them to decide when exactly to use it.) Zotero just does a PUT and doesn't place any restrictions on the request that should trigger that.
  • edited October 3, 2009
    For the Windows error, it looks like it's trying to create a .lnk file—i.e., a Windows shortcut—and failing. We'll see if we can reproduce this (and, if so, blacklist such files), but you might try removing the and DDQIPXZT.prop files from your WebDAV server to see if that fixes it. (If not, provide another Debug ID.)

    If that does fix it, check that directory on your other computer to see how the link got there. (It won't upload again unless you do a Reset File Sync History from the Sync->Reset pane of the Zotero prefs.)
  • edited October 6, 2009
    Windows: yep, that fixed it! Thanks!

    The file in question was a shortcut to a Deja Vu (.djvu) file; I had copied the link as part of a larger folder structure from a lab computer. I can send the .lnk file if it might help isolate the problem. Apart from being a shortcut file, the only potentially non-standard things I immediately note about it are: 1) the filename has 2 '.' characters; i.e. SayersCherry57.djvu.lnk. 2) The shortcut pointed to a file on a network computer in the lab, which, needless to say, is not normally accessible from my home computer or laptop. (Though I wouldn't expect either of these to cause any issue necessarily)
Sign In or Register to comment.