Not syncing library

I haven't been able to sync this library for 162 days.

I enabled debugging and see a lot of problems connecting to
1) https://api.zotero.org/keys/current
2) wss://stream.zotero.org/

I also can't send error reports or debug outputs.

My technical knowledge is limited. Excerpt from debug output is below - I'll keep a copy of the full output, but you'll have to instruct me how to get it to you or what part you need me to extract and post.

Seems *very* related to this post, but this a Linux machine (Fedora VM running on Qubes). I doubt this is just a Mac problem.

https://github.com/zotero/zotero/issues/2042

Thanks in advance - LR.


(3)(+0287258): Connecting to streaming server at wss://stream.zotero.org/

(3)(+0060050): WebSocket error

(1)(+0000003): WebSocket connection closed: 1006

...

(3)(+0000003): [ConcurrentCaller] Running function (0/4 running, 0 queued)

(3)(+0000003): HTTP GET https://api.zotero.org/keys/current

(1)(+0030007): HTTP GET https://api.zotero.org/keys/current failed with status code 0

(2)(+0000002): Channel status was 2152398850

(3)(+0000010): [ConcurrentCaller] Error in function (0/4, 0 in queue)
  • Also:

    version => 5.0.95, platform => Linux x86_64, oscpu => Linux x86_64, locale => en-US, appName => Zotero, appVersion => 5.0.95, extensions => ZotFile (5.0.16, extension), Zotero LibreOffice Integration (5.0.25.SA.5.0.95, extension)
  • First, 5.0.95 is outdated, and you should update to a current version before doing anything else.

    Beyond that, it just looks like your Zotero isn't able to connect to the internet at all, so see Connection Error. We can't really help beyond the information there — you'll need to debug this yourself on your computer.
  • Thanks

    Installed the 5.0.95, but having the same problems. Examining my system further, I've discovered problems with two other connection issues:

    a) curl calls on https (and possibly other protocols) - just fails to connect.
    b) gpg --keyserver [keyserver.of.your.choice] --recv-keys [fingerprint]

    I'm really outside my knowledge-base here, but can you point out to me the similarities that Zotero has to these protocols? Is it using curl under-the-hood, for example?
  • edited 8 days ago
    We can't help with general system troubleshooting, sorry. If curl can't connect to the internet, there's something very wrong with your system configuration.
  • That's really not what I am asking.

    You can tell me how Zotero connects to the internet.

    Whatever is going on on my system - that I have to investigate - it affects several functions.

    One possibility, for example, is that Zotero is using curl when it tries to contact https://api.zotero.org/keys/current.

    Allow me to restate: What protocol does Zotero use to contact https://api.zotero.org/keys/current, or wss://stream.zotero.org/? Is there a port that is requires? Something like that. Technical information about Zotero, please.

    I can then use that to find my own solutions.
  • edited 8 days ago
    Sorry, but you're asking questions you don't understand. "What protocol does Zotero use to contact [an HTTPS web address]" and "Is there a port that is required [to connect to an HTTPS web address without a port number]" are not questions that require answers from us, and if you don't understand that, you may want to ask someone to help you debug this.

    I linked to Connection Error above, which is all the Zotero-specific information that would be necessary to troubleshoot this.
  • [Solved]

    For those who follow, I can tell you what worked for me:

    1. Open your browser and go to about:config, search for "proxy"
    2. In Zotero, find the equivalent in Edit > Preferences Advanced > Config Editor, search for "proxy"
    3. Compare and contrast - I replicated what was in the browser, but!
    4. network.proxy.socks_remote_socks was default "True" in my browser, but not in Zotero. -> "True" and Zotero can communicate and update.

    My browser is Librewolf, a privacy oriented fork of Firefox. I use a VPN that provides a client, and a Shadowsocks proxy. (On Linux). YMMV.

    (Curiously, at the time of writing this offline, I am having problems logging into the forum now, but I suspect that's because the old Zotero had an old password, and things are all a bit slow to update after a reset.)
  • Update just now - password reset proved buggy.
    - my previous password stopped working.
    - reset facility rejected my 50-character password, demanding 32.
    - even a 32-character password was rejected 'because it was >32'. I removed some special characters and didn't get the error.
    - new password didn't work.
    - about 6-10 attempts (different login, different passwords) over 2 days and its finally let me in now.
  • CORRECTION:
    "network.proxy.socks_remote_socks" setting should be "network.proxy.socks_remote_dns".

    (writing late...)
Sign In or Register to comment.