Can't Link PDF in Zotero Desktop on Macbook Pro

Hi there, a few times now when I've opened Zotero on my Macbook, I notice that, for several of my references (not all of them), the icon indicating whether a PDF is or is not attached is an open circle (instead of a filled circle). I get the following message: "The attached file could not be found at the following path:

/Users/kh/Box/Research Literature/References/May_2021_HIGH May 2021 Coastal Community Resilience and Power in the United States.pdf

It may have been moved or deleted outside of Zotero, or a Linked Attachment Base Directory may be set incorrectly on one of your computers."

I have checked the base directory and it is set to the correct location (if it matters, I use Box as my storage/base directory). I've checked that the PDF files are in the folder in the base directory, and they are. When I have then tried to "Add Attachment" > "Attach Link to File" the icon blinks for a second but then does not add the linked file (icon stays an open circle; same error message as above).

Am I doing something wrong?
  • edited 11 days ago
    I figured out how to get the PDF re-linked (but not why it unlinked to begin with).

    Solution to Re-link PDF: When the error message appears (or right click on reference and "Show File" to get error message), click "Locate" and then navigate to location of file and select it.

    Going through the Attach Link to File method doesn't work in this case.
  • Can you provide a Debug ID for an attempt to add a linked file that fails? That should certainly work.
Sign In or Register to comment.