Updating citations = taking ages not actually finishing please help urgently

I am adding citations and it was going fine until my 6th one and now it keeps scanning through the 45 page document and not completing - what do I do. I have tried refreshing, re-starting zotero but it keeps doing the same thing. I have a deadline...Thanks
  • It's not entirely clear what's going on from your description (it could be various different issues), but because you said you have a deadline, here are two things to try to get this resolved immediately:

    1. If you're using a Mac, try switching to a Windows computer if you have that option. It will be much faster. https://forums.zotero.org/discussion/91573/zotero-word-connection-extremely-slow

    2. If a specific citation is causing an error, then you should remove and replace that citation. https://www.zotero.org/support/kb/debugging_broken_documents
  • Thanks djross3!

    I bailed in the end...but doing manually using zotero just not the plug in! I am on windows. I tried various citations but it did the same...Will let you know if I have any luck. thanks for getting back to me.
    Jess
  • Do you think it could be googledocs? I did the disabling multiple versions / review thing.
  • Integration with Google Docs is slower than with Word or LibreOffice, but you certainly shouldn't have a problem after six citations. We'd want to see a Debug ID from Zotero for an operation that was slow.
  • ok ill try next time and send to you if happens again ! cheers, jess
Sign In or Register to comment.