google doc zotero bibliography not updated


i introduced citations using zotero throughout the document but only a small fraction of the citations appears in the bibliography. also, sometimes zotero button is greyed out and inactive and i can't add more citations. your help will be approeciated.

thank you,
  • actually, i found a fix to the grey button problem, so now only the bibliography problem remains.
  • when i tried to change bibliography style like suggested in other posts, it says that my citations have been unlinked. i tried linking them manually again and they become unlinked again.
  • (Please don't post to multiple threads about the same issue.)

    If you have unlinked citations, you'll need to reinsert them for them to appear in the bibliography. See Why isn’t Zotero detecting my existing Google Docs citations? for the things that cause this and how to restore them.
  • this does not make sense to expect every collaborator to have zotero. my citations become unlinked and then I relink them again and then they become unlinked again.
  • edited August 28, 2021
    They don't need Zotero. They do need the Zotero Connector installed, as explained on the linked page, if they're going to be editing the document and cutting/pasting citations. This is a technical limitation of Google Docs.
  • ok, i will let them know.
Sign In or Register to comment.