Zotero won't save snapshots


When I attempt to save a webpage as (Web Page with Snapshot) or (Embedded Metadata) that triggers a message box indicating that a snapshot will be saved. But the result is a subitem that is either labeled with the same name as the main item or as "Snapshot", usually the former. In either case, the purported snapshot is actually the URL of the original webpage and is identical to that in the main item. The filename for the purported snapshot (however labeled) ends in .html and has a name that seems to be a string taken from the webpage's URL. When copied and used the URL indeed leads to the original webpage.

I have tried the following to solve the problem/identify its cause:
1, Used both FF and Edge with the same result
2. Restarted Zotero and tried each of the browsers again, again with the same result
3. Used two different Zotero profiles. Same result.
4. Rebooted my computer and tried both browsers and both Zotero profiles. Same result.
5. Checked database integrity for both profiles. No problems found.

This is not an isolated issue. It appears to occur for all webpages. Including the "New Discussion" page that I used to prepare this post.

Help would be greatly appreciated, since this I really need those snapshots!

  • edited August 28, 2021
    I think this is a misunderstanding. It sounds like you have snapshots. Snapshots also have a URL field that's shown in the right-hand pane, but there's still a local HTML file that's opened when you double-click the item or attachment, and shown via right-click → Show File. I'm not entirely sure why you think there's a problem, so you'd have to provide steps to reproduce for whatever you think is going wrong, with the info requested there.
  • edited August 28, 2021
    Thanks for the quick response! And you're right. The functionality that I need is (still) there.

    I think I understand the source of my confusion. In the past, I would see in the Snapshot pane a link to a file with enough of the path visible to identify that the file was indeed on my disk. I think that this link was in the Filename, but I don't remember for sure. Clicking on Snapshot would bring up that local file. Clicking on Snapshot icons still does this (which is great). Clicking on the blue hyperlink in the Snapshot pane goes to the original website. The Filename is inaccessible.

    Part of what confused me, I believe, is that sometimes Snapshots are labeled as such and sometimes they are labeled with the name of the webpage from which they are created. I have now confirmed that in both cases, clicking on the icon (as opposed to anything in the Snapshot pane) brings up the local file. Which is good and what I need.

    Also, is it possible that the format in which the Filename is presented was changed? Because I swear that it, or something in the Shortcut panel, formerly contained a filename in the form "[disk]:\[path]\filename.ext". Now I just get the filename.

    Steps to reproduce were given above, although presumably no longer relevant other than as to the label given to the snapshot (Snapshot v. webpage name). Related screenshots are here:
    https://www.dropbox.com/s/y0g23t9q45m5cb8/Zotero Snapshot issue 2021-08-28.docx?dl=0
Sign In or Register to comment.