Snow Leopard Terminal startup error

After upgrading to Snow Leopard I can't seem to be able to start Zotero from Terminal. I get the following error:

$ /Applications/ -P research
dyld: Library not loaded: /usr/lib/libsqlite3.dylib
Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security
Reason: Incompatible library version: Security requires version 9.0.0 or later, but libsqlite3.dylib provides version 1.0.0
/Applications/ line 131: 3463 Trace/BPT trap "$prog" ${1+"$@"}

I can then reopen Firefox, select the profile I need, and Zotero works fine from then on. But this means I can only run one FF profile at a time and I no longer see the log of Z's activities in the Terminal.

Perhaps I need to upgrade sqlite via macports? Would that break anything in Zotero?
  • edited September 30, 2009
    This appears to be a bug in Firefox (#513747). From that bug, it looks like executing Contents/MacOS/firefox-bin instead of Contents/MacOS/firefox should take care of things.
Sign In or Register to comment.