Files moved folders in desktop - can I undo? (Mac)

Just downloaded Zotero. I have always manually saved articles onto my desktop in a similar fashion to the following: /Users/tylerwiles/Desktop/Research/Saved Sources/Apparel:Equipment/Wetsuits/Surfing/"Article name"

However Zotero has decided to move it, from it's original manually filed location, to this example location: /Users/tylerwiles/Zotero/storage/8VWTAMRK/"Article name"

Is there a way to undo this? Or would I have to manually recategorize the papers again?
  • This is a misunderstanding. Zotero doesn't move files you add to it unless you hold down a modifier key when adding them — it just makes copies in its own data folder. So the files would still be in the original location as well unless you deleted them.

    Generally, if you're adding local files at all, you would drag to Zotero from a temporary location in a download folder and then delete the original file. If you want to keep files elsewhere on your disk, you can use linked files with the ZotFile plugin, but the moving and organizing is done for you — you wouldn't add from that location yourself.

    In any case, adding files directly isn't the standard way to get files into Zotero. Read through Adding Items to Zotero to understand the basic recommended workflows, which in most cases will handle downloading and saving files for you.
  • While Dan's description was the behavior for ever, I am seeing what coyote054 said using Zotero 5.0.97-beta.40+952663de7 on a Mac OS 10.14.6 with all plugins disabled. I drag a PDF from the Downloads folder, and after being added to a collection, the file gets deleted (not in Trash, but for good). Definitely not hitting shift or any other modifier key. Tried it with a three-button mouse on a Mac mini, and with a trackpad on a Macbook Pro just to be sure.

    In case it can't be reproduced, here is a Debug ID: D1466750951

    To be honest, I don't mind this behavior, because I usually delete the downloaded files, but this was still not expected.
  • edited August 30, 2021
    Oh, that's definitely a bug — I can reproduce that. The latest beta involved a complete rewrite of the collection and item trees, and this is likely a regression from that.

    @coyote054, are you using the Zotero beta? (If so, be sure to always say so when posting here.) Most of my answer still stands — you want to add temporary files to Zotero, delete the original, and let Zotero organize them for you (potentially with ZotFile's help) — but a regular drag isn't supposed to delete the original file.

    We'll fix this for the next beta.
Sign In or Register to comment.