Zotero connector not working

A few months ago my Zotero connector button stopped working - it used to work perfectly to import items from the web into my library. I'm using Chrome. I've tried everything on the 'troubleshooting problems saving to Zotero' page several times, and nothing has worked. Here's a URL where, when I click the connector button, nothing happens: https://www.nytimes.com/interactive/2021/08/24/world/vaccines-seniors.html. This uses the NYTimes.com translator.

I don't get any errors or warnings in these instances - there is no pop up window at all. Debug ID is D1427856121.
  • edited August 24, 2021
    (3)(+0000001): HTTP POST

    (3)(+0000092): Connector: Method ping failed with status 403
    Did you try disabling your other browser extensions? This would happen either because 1) some extension is interfering with the Zotero Connector's connection to Zotero or 2) proxy settings and/or security software on your computer is rerouting the Connector's requests. This is a 403 Forbidden response, which the Connector should never get from the app for a normal request (which is why it doesn't display anything — it's a totally unexpected state).
  • edited August 24, 2021
    Basically you'd want to follow these troubleshooting steps. They weren't written with this error in mind, but it basically indicates the same problem and would be fixed by the same steps, so we can probably just show the usual "Is Zotero running?" dialog that links to that page.
Sign In or Register to comment.