Sync deletes contents of active metadata text field

edited August 11, 2021
OSX, current Zotero version (, recent problem within the past few weeks I think.

Sometimes if I am typing (for example, in the "Publication" or "Series" field) while the sync completes, the text I have entered in the field disappears and the field is blank, while I'm still typing in the field.

I have noticed my text disappearing for about a week now, but I wasn't able to pinpoint the cause. I now just observed the sync arrow spinning, stopping, and my text being deleted, so that is almost certainly the cause. (My guess is that the sync is replacing the text of the field with whatever is saved on the server, instead of what I'm actively typing. It's often blank, because I'm usually typing in new metadata for a new item.)

I can try to find a way to document this in a video or a debug report, although I'm not so sure how reliably it happens, but it definitely does happen repeatedly. (Update: I tried to trigger this intentionally, and it did not happen, so it's inconsistent.)

(There was a recent discussion called "Note is deleting", which appears to have been deleted from the forum. I made a comment there, unsure if it was related or not, but now I have more information about the specific issue I'm experiencing. I hope this conversation doesn't get deleted too.)
  • edited August 11, 2021
    (The deleted thread was spam — it was a duplicate of an earlier thread with a link added.)
  • This is becoming intrusive in my workflow. I type out 10 words of a title in another language, including diacritics, etc., and then it disappears after a sync, so I have to start over. Sometimes this happens multiple times while trying to type out the same title.

    Any response about this issue? Is it a known issue? Is it easily fixable, and will that happen soon? Or is this something we just need to live with and work around? It's gotten to the point where I'll sometimes open a text document to type out anything long and write it there then copy and paste, or write a few words at a time and 'save' that by defocusing the text field, then going back, adding a few more words, etc., until the title is fully written out.

    (I work a lot with items that have not been digitized so I can't just import them easily from websites, and often in languages that are slow to type because I'm not fluent in reading them, but just enough to get by.)
  • If you can figure out how to reproduce it, we'd want a Debug ID for it. There haven't been other reports item fields, and I can't reproduce it.

    You'd want to identify some specific condition that was causing the item to be locally modified after upload — e.g., some invalid characters that were cleaned by the server.
  • edited August 31, 2021
    I was away from my computer for a while, and this has happened irregularly since. I finally caught one with a Debug ID. It's a long one, just running for most of today I think to see if it catches the error, which happens sporadically. It's at the very end of this: D824105658

    The steps to reproduce it aren't entirely clear. It doesn't happen every time (in fact, it seems rare and I haven't been able to do it intentionally), but it involves the following minimal conditions:
    1. Make changes to metadata for an item.
    2. Start typing in another field (e.g. title or series, etc.), especially if you're typing for a while or just leave the cursor sitting there for some time.
    3. Zotero automatically starts to sync (because of the changes in step 1).
    4. After the sync completes, the partially-completed field in step 2 is cleared, with whatever you just typed missing. I assume it is replacing the current text with whatever is stored on the server, which is typically blank for new metadata.

    To repeat, this does not happen every time, and if I try to create those conditions intentionally it doesn't seem to happen. But this has happened to me dozens of times over the last month or so. It seems particularly likely when I'm very slowly typing out metadata (often in a language I don't read very well, so I'm spending extra time checking that the diacritics are correct, etc.). For that reason this is particularly frustrating because it usually wipes out a title I've spent a full minute carefully typing, rather than just something I can type out in 3 seconds, etc.

    In the Debug ID above, the specific events were: I imported an item and then corrected some metadata (Place). Then I wanted to add the series, so I added the series number, and then started typing out the series name (in German) and was thinking about how much of it to capitalize, so I wrote it out slowly, and while I was doing that, the field was cleared during a sync, and I had to start again. The end of the Debug ID just before I submitted it was completing the Series correctly. (I hope that the Debug ID logs keystrokes, because otherwise since the field was active I don't know that anything will be reported here, just a blank field that remained blank until I completed it the second time.)

    I have tried to record a screen capture video to go along with a Debug ID, but since I can't seem to reproduce this on command, I haven't been successful with that. It only seems to happen when I'm genuinely working on carefully editing metadata... (Let me know if the video would be crucial to solving this, and I can try to do it again.)
Sign In or Register to comment.