Trouble moving collections between libraries

This discussion was created from comments split from: Trouble moving items between collections.
  • I have the same issue with "drag&drop"ing collections between libraries, the bug ID is: D802762814
  • (Please start new threads for new issues — the thread you posted to was several years old and about a different issue. I've moved this to a new thread.)
    [JavaScript Error: "Unix error 24 during operation pump (Too many open files)" {file: "(unknown module)" line: 0}]

    [JavaScript Error: "Upload request 1/EKZ326SJ failed"]

    [JavaScript Error: "Unix error 24 during operation DirectoryIterator on file /home/[…]/Zotero/storage/EKZ326SJ (Too many open files)" {file: "(unknown module)" line: 0}]
    What's the actual problem you're experiencing?

    How many items are you trying to copy?

    Your report shows an error we've never seen before, but I think it was earlier, during syncing. You submitted the debug output in the middle of the copy operation before anything seems to have gone wrong, suggesting you just didn't wait for it finish.
  • Hi there,

    Thank you for your response, I'm trying to copy a Collection, containing multiple Subcollections, from one Library to another Library using the Zotero app on Linux.

    The Collection has several Subcollection levels, up to 4, and probably contains about 500 references in total (not sure how to find the exact number since they are stored in several subcollections).

    I've just realised I might be running out of storage space. So I will sort this out first,
    Thank you for your help
  • To be clear, "Too many open files" wouldn't be about disk space, if that's what you mean.

    Regardless, though, you seem to have submitted the debug output in the middle of a perfectly normal copy, before anything had gone wrong — that's why I'm asking what the actual problem is that you're experiencing.
  • Thank you, I re-tried and waited but nothing happened (I could never see the Collection in the Library even after waiting for a while).

    Not sure if it is related but I tried again after purging my zotero space and deleting a group library that was running out of space (I am using Webdav so I moved the content of this group to My Library).

    The Collection copy worked perfectly after doing this.
  • edited August 12, 2021
    No, this has nothing to do with your online storage (and I'd strongly encourage you to ask before trying drastic troubleshooting steps that we don't recommend when you're already posting here). You very likely just hadn't waited long enough. Again, when you sent the debug output the first time, it was in the middle of a perfectly normal copying operation — there was no problem. If you're copying a very large number of items, it will just take some time. You can always open Help → Debug Output Logging → View Output to see if something is happening.
Sign In or Register to comment.